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Welcome to pbnArtist 

 

 
 
Thank you for using pbnArtist to create paint-by-number paintings and cross-stitch projects. 
 
This program is available as a trial version, or as a fully-functional version.  The trial version 
runs for a trial period of, in most cases, 15 days.  During this trial period, all functions operate 
normally, but any images that you save, print or copy to another program include an additional 
watermark that states it was generated using the program's trial version.  This watermark is 
eliminated when you activate the program to its fully-functional version. 
 
This user manual contains information to help you get started quickly.  It is divided into the 
following three sections: 
 
Creating your first paint-by-number and cross-stitch projects is described in the Getting Started 

guide. 
 
Tutorials are included in the How To section. 
 
Detailed information about the program commands and features are in the Reference Manual. 
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PART 1:  Getting Started 
 

 
Making your first Paint-By-Number and Cross-
Stitch Project 

 

 
 
The first time you run pbnArtist, the program will open with the Main Menu on the top of the 
screen, the Quickstart Panel on the left side of the screen, the Project Workspace on the right 
side of the screen, and the Standard and Edit Toolbars above the Project Workspace.  Some of 
these items can be moved, resized and/or hidden, so they might not appear in exactly these 
locations the next time you run the program. 
 
The first time you use pbnArtist to create a paint-by-number or cross-stitch project, use the 
Quickstart Panel.  This is the control panel with the tabs labeled Step 1, Step 2, and Step 3. 
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Step 1 

 
Begin by clicking the Step 1 tab to select the first step (if it is not already selected). 
 

 
 

Click New and select your digital photograph 
 

 
 
This will begin a new project and will open a window in which you can select the file containing 
your digital photograph.  Select the desired file. 
 
The file window will initially open in the last folder that you used to open or save a graphics or 
image file, but you can navigate from there to any folder on your computer. 
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Select the Picture Type. 
 

 
 
Use the radio buttons to select the image type.  In most cases, you should use the first button, 
labeled Digital Camera. 
The choices available are:  

 Digital Camera 
Use this setting for most photographs.  

 Scanned Print 
Use this setting for photographs that have been scanned into your computer 
using a scanner.  

 Newsprint 
Use this setting for half-tones and photographs that were scanned from 
newsprint.  Only use scanned photographs for which you own the copyright or for 
which you have received permission from the copyright holder.  

 Graphics 
Use this setting for images that were drawn by hand or images that were drawn 
using a computer drawing program.  This mode will produce drawing that follow 
the sharp corners and sharp color transitions in graphics images.  It will also run 
slightly slower than the other modes.  

 Custom 
Use this setting to customize the imaging parameters.  You may press the "Set" 
button, which will allow you to manually set the amount of softening and the step 
size (number of pixels) that will be used when converting your photo to either a 
paint-by-number or a cross-stitch project.  You can experiment with these values, 
but in general, you will get best results using large amounts of softening for very 
coarse pictures (like newsprint) and using small amounts of softening for very 
sharp images (like graphics).  You can also select the preset values that are 
used for the other settings. 

 
After you have processed the photograph, you may wish to return to this step to experiment with 
the other choices. 
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Step 2 
 
Click the Step 2 tab and click Run. 
 

 
 
Press the Run button to process your photograph. The button's label will change to Cancel, and 
the process will begin running.  You can watch your photograph change as it is being 
processed.  If you would like to stop the process, click Cancel. 
 
When the process has finished, the Quickstart Panel will automatically advance to Step 3.  On 
this panel you can select whether you want a paint-by-number project (using the Drawing tab) or 
a cross-stitch project (using the Cross Stitch tab). 
 

 
That's it! 
 
Your photograph has been processed into a project.  You may now select the project type and 
select from several ways to view and use your drawing.  The tabs at the top of the Step 3 
window allow you to view your project as a drawing (paint-by-number or coloring picture), a 
cross-stitch pattern, or the original photograph. 
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Step 3 
 
Drawing Tab 
 

 
 
Use the drawing tab to view your project as a paint-by-number or a coloring picture.  You can 
set the complexity as well as determine how to display numbers and lines within the picture.  
You can find more details by clicking here. 
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Cross Stitch Tab 
 

 
 
Use the cross stitch tab to view your project as a cross stitch or needlepoint pattern.  You can 
set the size and stitch count as well as determine how to display floss symbols and/or colors 
within the pattern.  If the pattern is too large to fit on a single page, it will be spread across 
multiple pages.  You can find more details by clicking here. 
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Photo Tab 
 

 
 
Use the photo tab to view your original photograph. 
 
 

Save your project. 
 
To save your entire project, including all of your settings and any work done, select Save Project 
As ... in the File Menu.  This will open a window that allows you to navigate to a desired folder 
and then save your project file.   
 
By default, your project file will have the same name as your original digital photograph, with the 
extension .pbn added at the end of the name. 
 

Save the selected view. 
 
To save the current view as a graphics file, select Save Graphics As ... in the File Menu.  This 
will open a window that allows you to navigate to a desired folder and then save the current 
view as a graphics file.  This window will open in the same folder that was used the last time you 
saved a graphics file, but you can navigate from there to any folder on your computer. 
 
By default, graphics files will be given a name that begins with either the project name or the 
original photo name, followed by the name of the view, followed by an extension that indicates 
the file format. 



pbnArtist User’s Manual 
 

  
Page 14 

 
  

 
Default view names that are used are shown here.  You may change these when you name the 
file: 
 

 <ProjectName>_PBN: 
The numbered paint-by-number drawing, ready for painting or coloring 
 

 <ProjectName>_LineDrawing: 
The un-numbered line drawing, ready for painting or coloring 

 

 <ProjectName>_ColorDrawing: 
The drawing with all colors filled in 

 

 <ProjectName>_Key: 
The list of paints or crayons used in you paint-by-number project 

 

 <ProjectName>_CrossStitch:   
The cross stitch or needlepoint pattern 

 

 <ProjectName>_csKey: 
The list of flosses used for your cross stitch or needlepoint pattern 

 

 <ProjectName>_Photo: 
The original photograph 

 
 
Possible file formats are: 
 

 .jpg: 
JPEG format 
 

 .bmp: 
Bitmap format 
 

 .gif: 
GIF format 
 

 .png: 
Ping format 
 

 .tif: 
Tiff format 
 

 .wmf: 
Windows Metafile format 
 

 .emf: 
Extended Windows Metafile format 
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In general, PNG format will give the best result for the drawing, cross stitch, and color key 
views, and JPEG will give best results for the photo view. 
 
So for example, if you are working on a photograph named MyFavoritePhoto, and you want to 
save the cross stitch pattern as a PNG file, the program will suggest the name 
MyFavoritePhoto_CrossStitch.png for the file.  But you may, of course, change this name when 
saving the file. 
 
 

Print the selected view 
 
To print the selected view, select Print from the File Menu. 
 
 

Copy the selected view 
 
To copy the selected view and paste it into another program, click Select All in the Edit Menu, 
and then click Copy in the Edit Menu. 
 
You may then navigate into your other program and use that program's Paste command to 
insert a copy of this view into that program. 
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Using a few of the Advanced Features 

 
 
The Quickstart Panel also includes advanced features that you can use to improve the 
appearance of your paint-by-number drawing.  Advanced features are available in Step 1 and in 
Step 3. 

 
Step 1 Advanced Features 
 
 

 
 
The Step 1 tab has advanced features in the second tab panel near the bottom of the panel. 
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Show Preview 
 

 
 
You may wish to experiment to find the best setting to use for each photograph.  The checkbox 
labeled "Show Preview" (at the bottom of the Step 1 window) will open a window that shows you 
a preview of the crayon colors assigned to your drawing.  The preview window will show any 
changes you make to the colors in your drawing as you make them.  This includes any of the 
changes you may make as described below. 
 
The preview feature is useful as a fast way to get the colors right in your final painting or 
stitching project.  As you experiment with different crayons and paints, you can immediately see 
how the colors you have selected will be applied to your photograph.  And if you don't like the 
way the program is assigning colors to your photograph, you can work with the color matching 
adjustments described below and immediately see how they will affect your project. 
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The Crayons Tab 
 

 
 
pbnArtist provides several groups of colors that you may include in your drawing.  These colors 
are grouped into Crayonboxes.  Click the dropdown arrow to view the list of crayonboxes and to 
choose the collection you would like to use. 
 
The dropdown box shows crayonboxes that are included with the program (system 
crayonboxes) and any custom crayonboxes that you have added or created.  Click here to learn 
how to create custom crayons.  Click here to learn how to import custom crayonboxes from an 
external file. 
 
The list below the crayonbox shows the crayons within the crayonbox.  The program 
automatically analyzes the colors in your photograph and then sorts the crayonbox, so that 
crayons at the top of the list represent the colors most frequently used in your photo. 
 
A number next to each crayon shows the percentage of the photograph that uses that color. 
 
A checkbox next to each crayon allows you to specify whether a crayon should be used or not.  
The program will assign the checked crayons to the colors in your photograph.  At each pixel in 
the photo, the program will select the closest crayon from the crayons you have checked, 
attempting to find the best crayon to match the color in that pixel. 
 
You must have at least one crayons checked before proceeding to step 2. 
 
The Number of Crayons numerical entry box below the list of crayons allows you to specify how 
many crayons should be included in your drawing.  Simply enter the number you desire, or use 
the up/down arrows to increase or decrease the number. 
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The Color Matching Tab 
 

 
 
Paint-By-Number Artist allows you to adjust the color-matching that is used to select crayons for 
your drawing.  You adjust the brightness, contrast, saturation and tint in the crayons that are 
selected and assigned to your drawing. 
 
When you change a color matching value, you are telling the program to select crayons based 
on the change you have made.  So for example, if you increase the brightness slider, you are 
telling the program to try to find crayons that are brighter than the actual pixel colors. 
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The Tools Tab 
 

 
 
You can edit the original photo by clicking the Edit Photo button.  This provides you with tools 
that can crop the photo, paint colors onto the photo, soften the focus in parts of the photo, or 
enhance the brightness, contrast and saturation of parts of the photo. 
 
Editing the photograph is explained in detail here. 
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Step 3 Advanced Features 

 
The Step 3 tab allows you to display your project as either a paint-by-number or coloring picture, 
or as a cross stitch or needlepoint pattern.  The advanced features on this tab allow you to 
make a wide variety of changes to the way these projects are displayed. 
 
 

 
The Drawing Tab 
 

 
 
Use the drawing tab to view your project as a paint-by-number or a coloring picture.  You can 
set the complexity as well as determine how to display numbers and lines within the picture.  
What follows is a brief description of how these options work.  You can find more details by 
clicking here. 
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Sketch Mode and Patch Mode 
 

 
 
Two drawing modes are available for your drawing -- sketch mode and patch mode.  Sketch 
mode draws lines that give a more lifelike view of your picture.  Patch mode draws lines exactly 
where the colors change, giving a view that will show the actual colors more accurately after the 
picture has been painted or colored. 
 
 

Select the Drawing View. 
 
Use the radio buttons to select the view being displayed.  You may select from the following 
views:  Numbers (a paint-by-number picture), No Numbers (a line drawing suitable for coloring), 
Colored (the drawing with all colors filled-in) and Key (the list of crayons, paints, or other media 
used in your picture). 
 
 

Adjust the Drawing Complexity. 
 
Use the sliders to adjust the difficulty level of your drawing. 
 
 

Additional Settings in the Drawing Tab 
 
The next set of checkboxes allow you to select how numbers are displayed for very small 
patches of color in your picture.  You may elect to have the number offset from a patch with an 
arror pointing into the center of the patch, or you may elect to not display numbers for these 
small patches. 
 
Below these checkboxes is a set of radio buttons that allow you to select the type of drawing 
being displayed.  You may select sketch mode or patch mode, or a combination of both.  You 
can also specify the type of line (color and thickness) used for each mode, and you can elect to 
have a frame drawn around your picture. 
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Number Spacing 
 
The Number Spacing numerical entry box lets you adjust the maximum distance between the 
numbers that indicate crayon colors on you picture.  This value may be specified in inches or 
centimeters by checking the appropriate radio button. 
 
 

Font Button 
 
The Font button allows you to specify the font used for color numbers in your paint-by-number 
view. 
 
 

Tools Button 
 
The Tools button provides tools that can draw or erase lines on your drawing, and that can 
change the crayons that are used for portions of your drawing. 
 
Editing the drawing using these tools is explained in detail here. 
 
 

Size Button 
 
The size button allows you to specify the size of your drawing (in inches or centimeters) when it 
is printed.  You also have the option to print the drawing on a single page of paper or across 
multiple pages. 
 
 

Icon Button 
 
The Icon button changes the icon that is used in the color key.  The color key provides a list of 
the colors used in your picture.  Each color is shown using an icon.  The available icons are 
crayon, pencil, pen, chalk, marker, paint brush, spool of thread, ball of yarn, button, or text only. 
 
 

 
  



pbnArtist User’s Manual 
 

  
Page 25 

 
  

The Cross Stitch Tab 
 

 
 
Use the cross stitch tab to view your project as a cross stitch or needlepoint pattern.  You can 
set the size and stitch count as well as determine how to display floss symbols and/or colors 
within the pattern.  What follows is a brief description of how these options work.  You can find 
more details by clicking here. 
 

Select the Cross Stitch View. 
 
You can display either the cross stitch pattern or the color key, which shows the flosses used in 
your project. 
 

Stitch Count and Size 
 
The set of numeric boxes near the top of this window allow you to set the stitch count (number 
of stitches per inch or per centimeter) to agree with the fabric you are using for your cross stitch 
project, and the total size of your project, counted in stitches.  The program automatically 
displays this size converted to either inches or centimeters, so as you change the number of 
stitches you can see the equivalent size. 
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Title and Header 
 
This checkbox causes patterns to be displayed with a title and additional information at the top 
of the page.  If the pattern is large enough to cover multiple pages, the header also includes a 
map of the pages which shows where each page fits into the overall pattern. 
 
If you want your pattern to fit on one page, you will probably need to have this option turned off. 
 
 

Grid Numbers 
 
Your project have numbers along the sides of the pattern, making it easier to count stitches, or 
you can leave these out. 
 
 

Stitch Symbols 
 
Your pattern can display symbols for each floss being uses, or you can turn this option off and 
show the floss color instead.  When using symbols, the program selects from the character fonts 
available on your computer. 
 
 

Stitch Colors 
 
Select this option to display the floss color for every stitch shown in your pattern. 
 
 

Backstitches 
 
The sketch mode lines, described for the drawing tab, can be overlaid on top of your cross stitch 
pattern.  These can be shown as individual stitches (single strands that extend horizontally, 
vertically, or diagonally across individual intersections in the weave) or as a line drawing (similar 
to the sketch line mode in the drawing tab).  You can change the color, thickness, and 
complexity level of these backstitches by clicking the Settings: button. 
 
 

Portrait or Landscape 
 
Your cross stitch pattern can be printed from any computer picture.  This option selects whether 
the pattern will be printed vertically (portrait) or horizontally (landscape) on the page.  If the 
pattern is too large to fit on a single sheet of paper, it will automatically be spread across 
multiple pages.  (You can return it to a single page by reducing the size of the project or by 
selecting smaller font sizes). 

 
Number Stitches From 
 
This option is used along with the Show Grid Numbers option.  You can elect to have the stitch 
numbering start from any corner or from the center of the pattern. 
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Font Button 
 
You can use the font button to specify the font used for the title and labels shown on your cross 
stitch pattern. 
 
 

Tools Button 
 
You can used the tools button to activate editing tools to make changes to your pattern.  You 
can change the colors that are used for individual stitches or for groups of stitches.  Editing a 
cross stitch pattern is similar to editing a coloring or paint-by-num picture, and is described in 
more detail here. 
 
 

Symbols Button 
 
Cross stitch patterns show the floss used for each stitch by showing a symbol that is unique for 
each stitch.  pbnArtist uses the character fonts that are available on your computer, primarily 
using dingbat font types if they are available on your computer.  You can change the collection 
of symbols by clicking the symbols button. 
 
For more fun with your cross stitch patterns, you might enjoy adding additional symbol fonts.  
There are a wide variety of symbol fonts available on the internet, and many of these fonts are 
available for free.  To find these, search the internet using the search term "dingbat fonts." 
 
After you have found and installed new symbol fonts onto your computer, use the symbols 
button to select and add each symbol to your collection. 
 
 

Icon Button 
 
The Key view shows each floss used in your pattern, drawing each floss as a colored icon.  
Normally, it uses the default icon that is defined for each crayonBox, but you can use the icon 
button to select a different icon. 
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Printing tip:  Papers for Crayons and Paints 

 
 
If you are printing a drawing that will be colored using crayons, pencils or other art media, you 
may encounter a problem.  Most papers that are designed for computer printers are coated with 
a material that gives them a shiny finish.  This is desirable for most types of printouts, but it can 
prevent drawing materials from adhering to them.  You might notice that crayons, for example, 
slide off of this finish without leaving much color. 
 
Art papers, on the other hand, are designed to work well with these drawing media.  Art papers 
have a coarse finish, which provides a so-called bite that causes these colors to adhere. 
 
But art papers, unfortunately, are usually cut to sizes that don't fit computer printers, and they 
may be able to damage your printer.  Especially stiff or thick papers might damage the rollers 
that push paper through your printer.  The lack of finish on these papers may cause printer inks 
to leave the paper and stay on the rollers, causing smears on future printouts. 
 
There are two options you may wish to try.  For coloring pages, using crayons,  we recommend 
using 100% Cotton Resume Paper, that is specifically designed for inkjet or laser printers.  This 
type of paper has a coarser finish that will adhere well to coloring materials, and it will work well 
with your home computer printer.  100% Cotton Resume Paper is produced by several well-
known paper manufacturers, and is available at most office supply stores or college 
bookstores.  Check the label, and make sure that the paper you are using is inkjet printer 
compatible, or laser printer compatible, depending on the type of printer you are using. 
 
For paintings, purchase a tablet of artist's paper that is designed specifically for the type of paint 
you will be using.  This paper will probably be two large for your printer, but you can easily cut it 
to a smaller size.  In most cases, it will only be necessary to trim it to the correct width; the 
longer length should still work with most printers.  Test the result -- the ink or toner your printer 
uses may not adhere perfectly to this type of paper, but it should be good enough to enable you 
to complete your painting. 
 
But be careful when using these papers.  Some printers are not designed to use thick papers, 
and other printers, while compatible, may still require you to use a special "thick paper" setting.  
Incorrectly using thick paper can, in some cases, cause the printer's rollers to wear-out 
prematurely, preventing them from working properly with thinner papers.  Check your printer's 
user manual before using thick papers. 
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Program Activation 

 

 
 
We hope you have been enjoying pbnArtist, and that the Getting Started section of this user 
manual has helped you learn how to use the program. 
 
If you are using the trial version of the program, we hope that you will activate to the fully-
functional version. 
 
To activate the program, you can purchase an activation code by clicking the Buy Now button.  
This button appears in the notification window that appears when the trial version of the 
program is started. 
 
You can also display the notification window using the Software Activation command in the Help 
Menu. 
 
Clicking the Buy Now button will open your internet browser to a web page where you can 
purchase the program.  Upon completing your purchase, you will receive an email that gives 
you an activation code.  Activate the program by copying this code into the activation box that is 
in the notification window. 
 
To make this a little easier, you can copy the activation code from your email by double-clicking 
it (or simply selecting it), and then right-clicking to select "Copy".  In the program's notification 
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window, simply click the "Paste" button to paste the code into the activation box. 
 
You can activate either online (automatically) or manually by sending an email request. 
 
To activate online, select the "Online Activation" option, insert your activation key in the 
"Activation Key" textbox, and click "Activate". 
 
To activate manually, select the "Email Activation" option and insert your activation key in the 
"Activation Key" textbox.  The "Compose Email" button will become active when you have 
inserted a correctly formatted key.  Click the "Compose Email" button to get instructions on how 
to email the request, copy the information into an email message, and send it.  You will receive 
a response that includes a computer key.  When you receive the response, return to this 
window, again select the "Email Activation" option, insert both the activation key and the 
computer key in their respective text boxes, and click "Activate". 
 
 

Upgrading from the Basic Version to the Cross Stitch Version 
 
Use the Software Activation window to upgrade from the Basic version of pbnArtist to the Cross 
Stitch version. 
 
First, run About pbnArtist in the Help Menu to make sure you are running version 2 of pbnArtist.  
If you have an earlier version, you will need to download the newer version at 

http://www.pbnArtist.com. 

 
If you are already running the basic mode of version 2, open the Software Activation command 
in the Help Menu.  The activation button will be relabeled to "upgrade".  Press the Upgrade 
button to enable the textbox and then paste your new license key in the box.  The button will 
now be relabeled "activate" again.  Press the Activate button and wait for the dialog to say that 
your upgrade was successful (It might take as long as two minutes, depending on the internet 
connection). 
 
Once again, thank you for trying pbnArtist, and we hope that you are enjoying this program! 
 
 
 
  

http://www.pbnartist.com/
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PART 2:  Tutorials 
 
 

 
How to Create a Project 
 
 

Creating a project using the Quickstart Panel 

 

 
 
The first time you run Paint-By-Number Artist, the program will open with the Main Menu on the 
top of the screen, the Quickstart Panel on the left side of the screen, the Project Workspace on 
the right side of the screen, and the Standard and Edit Toolbars above the Project Workspace.  
Some of these items can be moved, resized and/or hidden, so they might not appear in exactly 
these locations the next time you run the program. 
 
The first time you create a paint-by-number drawing, use the Quickstart Panel.  This is the 
control panel with the tabs labeled Step 1, Step 2, and Step 3. 
 
Begin by clicking Step 1 to select the first step (if it is not already selected). 
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Click New. 
 
This will begin a new project and will open a window in which you can select the file containing 
your digital photograph.  Select the desired file. 
 
 

Select the photograph type. 
 

 
 
Select the type of photograph.  In most cases, you should use the first choice from the left, 
labeled Digital Camera. 
 
The choices available are:  
 

 Digital Camera 
Use this setting for most photographs.  

 

 Scanned Print 
Use this setting for photographs that have been scanned into your computer using a 
scanner.  

 

 Newsprint 
Use this setting for half-tones and photographs that were scanned from newsprint.  Only use 
scanned photographs for which you own the copyright or for which you have received 
permission from the copyright holder.  
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 Graphics 
Use this setting for images that were drawn by hand or images that were drawn using a 
computer drawing program.  This mode will produce drawing that follow the sharp corners 
and sharp color transitions in graphics images.  It will also run slightly slower than the other 
modes.  

 

 Custom 
Use this setting to customize the imaging parameters.  You may press the "Set" button, 
which will allow you to manually set the amount of softening and the step size (number of 
pixels) that will be used when converting your photo to either a paint-by-number or a cross-
stitch project.  You can experiment with these values, but in general, you will get best results 
using large amounts of softening for very coarse pictures (like newsprint) and using small 
amounts of softening for very sharp images (like graphics).  You can also select the preset 
values that are used for the other settings. 

 
 
After you have processed the photograph, you may wish to return to this step to experiment with 
the other choices. 
 
 

Click the Step 2 tab. 
 

 
 

Click Run. 
 
The button's label will change to Cancel, and the process will begin running.  You can watch 
your photograph change as it is being processed.  If you would like to stop the process, click 
Cancel. 
 
When the process has finished, the Quickstart Panel will automatically advance to Step 3. 
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That's it! 
 
Your photograph has been processed into a project.  You may now select the project type and 
select from several ways to view and use your drawing.  The tabs at the top of the Step 3 
window allow you to view your project as a drawing (paint-by-number or coloring picture), a 
cross-stitch pattern, or the original photograph. 
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Drawing Tab 
 

 
 
Use the drawing tab to view your project as a paint-by-number or a coloring picture.  You can 
set the complexity as well as determine how to display numbers and lines within the picture.  
You can find more details by clicking here. 
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Cross Stitch Tab 
 

 
 
Use the cross stitch tab to view your project as a cross stitch or needlepoint pattern.  You can 
set the size and stitch count as well as determine how to display floss symbols and/or colors 
within the pattern.  You can find more details by clicking here. 
 
 

Photo Tab 
 

 
 
Use the photo tab to view your original photograph. 
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Creating a project using the Advanced 
Features 

 
 
The Quickstart Panel also includes advanced features that you can use to improve the 
appearance of your paint-by-number drawing.  Advanced features are available in Step 1 and in 
Step 3. 
 
 

Step 1 
 
In step1, the advanced features are organized into three tabs, the Crayons tab, the Color 
Matching tab, and the Tools tab. 
 
Step 1 also includes a preview window, so you can make changes and see how they will affect 
your project before processing the photograph.  To enable the preview, click the Show Preview 
checkbox near the bottom of the panel. 
 
 

The Crayons Tab 
 

 
 
pbnArtist provides several groups of colors that you may include in your drawing.  These colors 
are grouped into Crayonboxes.  Click the dropdown arrow to view the list of crayonboxes and to 
choose the collection you would like to use. 
 
The dropdown box shows crayonboxes that are included with the program (system 
crayonboxes) and any custom crayonboxes that you have added or created.  Click here to learn 
how to create custom crayons.  Click here to learn how to import custom crayonboxes from an 
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external file. 
 
The list below the crayonbox shows the crayons within the crayonbox.  The program 
automatically analyzes the colors in your photograph and then sorts the crayonbox, so that 
crayons at the top of the list represent the colors most frequently used in your photo. 
 
A number next to each crayon shows the percentage of the photograph that uses that color. 
 
A checkbox next to each crayon allows you to specify whether a crayon should be used or not.  
The program will assign the checked crayons to the colors in your photograph.  At each pixel in 
the photo, the program will select the closest crayon from the crayons you have checked, 
attempting to find the best crayon to match the color in that pixel. 
 
You must have at least one crayons checked before proceeding to step 2. 
 
The Number of Crayons numerical entry box below the list of crayons allows you to specify how 
many crayons should be included in your drawing.  Simply enter the number you desire, or use 
the up/down arrows to increase or decrease the number. 
 
 

The Color Matching Tab 
 

 
 
Paint-By-Number Artist allows you to adjust the color-matching that is used to select crayons for 
your drawing.  You adjust the brightness, contrast, saturation and tint in the crayons that are 
selected and assigned to your drawing. 
 
When you change a color matching value, you are telling the program to select crayons based 
on the change you have made.  So for example, if you increase the brightness slider, you are 
telling the program to try to find crayons that are brighter than the actual pixel colors. 
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The Tools Tab 
 

 
 
You can edit the original photo by clicking the Edit Photo button.  This provides you with tools 
that can crop the photo, paint colors onto the photo, soften the focus in parts of the photo, or 
enhance the brightness, contrast and saturation of parts of the photo. 
 
Editing the photograph is explained in detail here. 
 
 

Step 3 
 
The Step 3 tab allows you to display your project as either a paint-by-number or coloring picture, 
or as a cross stitch or needlepoint pattern.  The advanced features on this tab allow you to 
make a wide variety of changes to the way these projects are displayed. 
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The Drawing Tab 
 

 
 
Use the drawing tab to view your project as a paint-by-number or a coloring picture.  You can 
set the complexity as well as determine how to display numbers and lines within the picture. 
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Sketch Mode and Patch Mode 
 

 
 
Two drawing modes are available for your drawing -- sketch mode and patch mode.  Sketch 
mode draws lines that give a more lifelike view of your picture.  Patch mode draws lines exactly 
where the colors change, giving a view that will show the actual colors more accurately after the 
picture has been painted or colored. 
 
 

Select the Drawing View. 
 
Use the radio buttons to select the view being displayed.  You may select from the following 
views:  Numbers (a paint-by-number picture), No Numbers (a line drawing suitable for coloring), 
Colored (the drawing with all colors filled-in) and Key (the list of crayons, paints, or other media 
used in your picture). 
 
 

Adjust the Drawing Complexity. 
 
Use the sliders to adjust the difficulty level of your drawing. 
 
 

Additional Settings in the Drawing Tab 
 
The next set of checkboxes allow you to select how numbers are displayed for very small 
patches of color in your picture.  You may elect to have the number offset from a patch with an 
arrow pointing into the center of the patch, or you may elect to not display numbers for these 
small patches. 
 
Below these checkboxes is a set of radio buttons that allow you to select the type of drawing 
being displayed.  You may select sketch mode or patch mode, or a combination of both.  You 
can also specify the type of line (color and thickness) used for each mode, and you can elect to 
have a frame drawn around your picture. 
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Number Spacing 
 
The Number Spacing numerical entry box lets you adjust the maximum distance between the 
numbers that indicate crayon colors on you picture.  This value may be specified in inches or 
centimeters by checking the appropriate radio button. 
 

Font Button 
 
The Font button allows you to specify the font used for color numbers in your paint-by-number 
view. 
 
 

Tools Button 
 
The Tools button provides tools that can draw or erase lines on your drawing, and that can 
change the crayons that are used for portions of your drawing. 
 
Editing the drawing using these tools is explained in detail here. 
 
 

Size Button 
 
The size button allows you to specify the size of your drawing (in inches or centimeters) when it 
is printed.  You also have the option to print the drawing on a single page of paper or across 
multiple pages. 
 
 

Icon Button 
 
The Icon button changes the icon that is used in the color key.  The color key provides a list of 
the colors used in your picture.  Each color is shown using an icon.  The available icons are 
crayon, pencil, pen, chalk, marker, paint brush, spool of thread, ball of yarn, button, or text only. 
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The Cross Stitch Tab 
 

 
 
Use the cross stitch tab to view your project as a cross stitch or needlepoint pattern.  You can 
set the size and stitch count as well as determine how to display floss symbols and/or colors 
within the pattern. 
 
 

Select the Cross Stitch View. 
 
You can display either the cross stitch pattern or the color key, which shows the flosses used in 
your project. 
 
 

Stitch Count and Size 
 
The set of numeric boxes near the top of this window allow you to set the stitch count (number 
of stitches per inch or per centimeter) to agree with the fabric you are using for your cross stitch 
project, and the total size of your project, counted in stitches.  The program automatically 
displays this size converted to either inches or centimeters, so as you change the number of 
stitches you can see the equivalent size. 
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Grid Numbers 
 
Your project have numbers along the sides of the pattern, making it easier to count stitches, or 
you can leave these out. 
 
 

Stitch Symbols 
 
Your pattern can display symbols for each floss being uses, or you can turn this option off and 
show the floss color instead.  When using symbols, the program selects from the character fonts 
available on your computer. 
 
 

Stitch Colors 
 
Select this option to display the floss color for every stitch shown in your pattern. 
 
 

Backstitches 
 
The sketch mode lines, described for the drawing tab, can be overlaid on top of your cross stitch 
pattern.  These can be shown as individual stitches (single strands that extend horizontally, 
vertically, or diagonally across individual intersections in the weave) or as a line drawing (similar 
to the sketch line mode in the drawing tab).  You can change the color, thickness, and 
complexity level of these backstitches by clicking the Settings: button. 
 
 

Portrait or Landscape 
 
Your cross stitch pattern can be printed from any computer picture.  This option selects whether 
the pattern will be printed vertically (portrait) or horizontally (landscape) on the page.  If the 
pattern is too large to fit on a single sheet of paper, it will automatically be spread across 
multiple pages.  (You can return it to a single page by reducing the size of the project or by 
selecting smaller font sizes). 
 
 

Number Stitches From 
 
This option is used along with the Show Grid Numbers option.  You can elect to have the stitch 
numbering start from any corner or from the center of the pattern. 
 
 

Font Button 
 
You can use the font button to specify the font used for the title and labels shown on your cross 
stitch pattern. 
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Tools Button 
 
You can used the tools button to activate editing tools to make changes to your pattern.  You 
can change the colors that are used for individual stitches or for groups of stitches.  Editing a 
cross stitch pattern is similar to editing a coloring or paint-by-num picture, and is described in 
more detail here. 
 
 

Symbols Button 
 
Cross stitch patterns show the floss used for each stitch by showing a symbol that is unique for 
each stitch.  pbnArtist uses the character fonts that are available on your computer, primarily 
using dingbat font types if they are available on your computer.  You can change the collection 
of symbols by clicking the symbols button. 
 
For more fun with your cross stitch patterns, you might enjoy adding additional symbol fonts.  
There are a wide variety of symbol fonts available on the internet, and many of these fonts are 
available for free.  To find these, search the internet using the search term "dingbat fonts." 
 
After you have found and installed new symbol fonts onto your computer, use the symbols 
button to select and add each symbol to your collection. 
 
 

Icon Button 
 
The Key view shows each floss used in your pattern, drawing each floss as a colored icon.  
Normally, it uses the default icon that is defined for each crayonBox, but you can use the icon 
button to select a different icon. 
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Creating a project using the Menus and 
Toolbars 

 

 

 

 
 
The first time you run Paint-By-Number Artist, the program will open with the Main Menu on the 
top of the screen, the Quickstart Panel on the left side of the screen, the Project Workspace on 
the right side of the screen, and the Standard and Edit Toolbars above the Project Workspace.  
Some of these items can be moved, resized and/or hidden, so they might not appear in exactly 
these locations the next time you run the program. 
 
Rather than using the Quickstart Panel, you may prefer to run the program using the Main Menu 
or the Toolbars.  You may prefer these options because you can hide the Quickstart Panel, 
making more space available to the Project Workspace, or because you may find the toolbar 
buttons easier to use. 
 
 

Show or Hide the Quickstart Panel 
 
If you would like to hide the Quickstart Panel, click the Toggle Quickstart Panel button shown 
here, which is in the Standard Toolbar.  You can also hide the Quickstart Panel by using the 
Toolbars command in the View Menu. 
 
 

Move the toolbars 
 
The toolbars can be moved (docked) to any of the four sides of the project workspace.  To move 
a toolbar, select its docking handle shown here, and drag to the desired location. 
 
 

Enable or Disable Popups 
 
If you would like a quick reminder telling you what each toolbar button does, enable the Show 
Popups command in the Help Menu.  When you allow the cursor to hover over a button, a brief 
description will appear telling you what the button does.  After you have become familiar with 
these buttons, you may wish to disable these popups by removing the check next to the Show 
Popups command. 
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Click New or Open 
 
Create a new project by clicking the New button, or open an existing project by clicking the 
Open button.  Both of these buttons are on the Standard Toolbar.  You can also use the New 
Project From Photograph, and Open Project commands from the File Menu. 
 
This will either begin a new project and will open a window in which you can select the file 
containing your digital photograph, or will open an existing project which you saved previously. 
 
The New Project command will initially open in the folder you have been using for graphics 
files.  The Open Project command will initially open in the folder you have been using for project 
files.  This is for your convenience, allowing you to keep projects and images in separate folders 
if you desire.  Or you can use the same folder for both types of files.  These locations will reset 
every time you open or save a project or image file. 
 
 

Select the photograph type. 
 
Select the photograph type using the Process Settings --> Photograph Type command in the 
Edit Menu.  In most cases, you should use the second choice from the left, labeled Digital 
Camera. 
 
After you have processed the photograph, you may wish to experiment with the other choices 
and re-process the photograph. 
 
 

Select the appropriate Crayon settings and Color-Matching Setting 
 
By default, the crayon settings and the color-matching setting will be the same as the last time 
you used the program if this is a new project, or the settings that were saved with the project if 
this is an existing project. 
 
Crayon selections and color matching can not be changed from the main menu.  To change 
these, you will need to use the Step 1 of the Quickstart Panel.  You may need to show the panel 
temporarily using the Toggle Quickstart Panel command that was described above. 
 
 

Process the Photograph 
 
Begin the process by clicking the Process Photo button shown above, or by using the Process 
Photograph in the Edit Menu. 
 
You can watch your photograph change as it is being processed. 
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Cancel the Process (if you want) 
 
If you would like to stop the process, click the Cancel button shown above, or use the Cancel 
Process in the Edit Menu.  You can also cancel the process by typing the ESC key or Ctrl-C on 
your computer keyboard. 
 
 

Advanced Functions 
 
The advanced functions described earlier can also be found in the Main Menu and on the 
Standard Toolbar and on the Edit Toolbar.  You identify each button by allowing the cursor to 
hover over the buttons in the toolbars, or by studying the Reference Manual. 
 
(Hovering over a button will only work if the Show Popups command has been enabled in the 
Help menu). 
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How To View and Use The Project 

 
 
How to select views 

 

 
 
You can use either the Main Menu or the Quickstart Panel to select the drawing view.  In the 
main menu you will find these commands in the View Menu.  In the Quickstart Panel you will 
find this selection under Step 3 in either basic or advanced mode. 
 
In the View Menu, these choices act as radio buttons.  When you select one, a bullet will appear 
next to the choice you have selected and will disappear from the previous choice.  In the 
Quickstart Panel, the radio buttons will operate in a similar manner. 
 
In the view menu, you can select the drawing view, the cross stitch view, or the photograph view 
(assuming that you have already processed the photograph into a project).  Below each of these 
selections is an entry named options that you can click to specify the display options for that 
view. 
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How to print drawing views 

 

 
 
To print the selected view, click the Print button in the Standard Toolbar, or select the Print 
command from the File Menu.  The program will then print the same view that is currently 
displayed in the work area. 
 

 
How to save a view as a Graphics File 

 
 
To save the current view as a graphics file, select Save Graphics As ... in the File Menu (there is 
no equivalent shortcut in either of the toolbars).  This will open a window that allows you to 
navigate to a desired folder and then save the current view as a graphics file.  This window will 
open in the same folder that was used the last time you saved a graphics file, but you can 
navigate from there to any folder on your computer. 
 
By default, graphics files will be given a name that begins with either the project name or the 
original photo name, followed by the name of the view, followed by an extension that indicates 
the file format.  You can change the name when saving the file. 
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View names that are used are: 

 _PBN 
The numbered paint-by-number drawing, ready for painting or coloring 
 

 _LineDrawing 
The un-numbered line drawing, ready for painting or coloring 
 

 _ColorDrawing 
The drawing with all colors filled in 
 

 _Key 
The list of paints or crayons used in you paint-by-number project 
 

 _CrossStitch 
The cross stitch or needlepoint pattern 
 

 _csKey 
The list of flosses used for your cross stitch or needlepoint pattern 
 

 _Photo 
The original photograph 

 
Possible file formats are: 

 .jpg 
JPEG format 
 

 .bmp 
Bitmap format 
 

 .gif 
GIF format 
 

 .png 
Ping format 
 

 .tif 
Tiff format 
 

 .wmf 
Windows Metafile format 
 

 .emf 
Extended Windows Metafile format 

 
In general, PNG format will give the best result for the drawing and color key views, and JPEG 
will give best results for the photo view. 
 
In some cases, large drawings or multiple page cross stitch patterns will be saved into multiple 
files.  In this case, each file name will have a file number added to the name. 
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How to Copy and Paste a drawing view 

 

 
To copy the selected view and paste it into another program, click the Select All button on the 
Standard Toolbar, or use the Select All command in the Edit Menu.  Then immediately click the 
Copy button on the Standard Toolbar, or use the Copy command in the Edit Menu. 
 
You may then navigate into your other program and use that program's Paste command to 
insert a copy of this view into that program. 
 

 
You may have also noticed that the Standard Toolbar includes buttons for the Cut, Crop and 
Paste operations.  These commands are only available if you are viewing the photograph, and 
they are used for making alterations to the photograph. 
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How to save a project file 

 

 
 
To save your project, select Save Project As ... in the File Menu.  This will open a window that 
allows you to navigate to a desired folder and then save your project file.   
 
By default, your project file will have the same name as your original digital photograph, with the 
extension .pbn added at the end of the name. 
 

 
 
You can also save your project by clicking the Save button shown here, which is on the 
Standard Toolbar, or by using the Save command in the File Menu.  These commands will ask 
you to specify a project name and location if it is the first time you have saved this project, or will 
immediately save the project if you have already defined these with the Save Project As ... 
command. 
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How to Resize or Print on Multiple Pages 

 
 
Resizing or Printing on Multiple Pages 

 

 
 
The photograph can be resampled, which means its resolution can be changed, using the 
Image Size command in the File Menu.  You can change this value by adjusting either the width 
or height of the picture in pixels, or by entering a total number of megapixels.  (When you enter 
a total amount, it may be necessary for the program to adjust the number slightly so that the 
ratio of width to height doesn't change). 
 
This window can also be used to specify the size of drawing views, in inches or centimeters.  
You may select a size that is larger than a single sheet of paper.  When you do this, drawings 
will automatically be printed across multiple sheets of paper. 
 
Sometimes it is desirable to save a drawing view as a graphics file but to have it split across 
multiple files, so that the saved files will be identical to large views that were printed across 
several pages.  Clicking the Split Saved Graphics ... checkbox will automatically save views into 
multiple graphics files. 
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How to Create and Share Custom Crayons 

 
 
Creating Custom Crayons 

 

 
 
You can use the Custom Crayon Editor to create custom crayons that you can use in your 
project.  This page gives step-by-step instructions to create a new group of crayons.  You can 
also read a detailed description of the Custom Crayons Editor in the Reference Manual. 
 
 

Activate the editor 
 
Click the Custom Crayons button shown here, which is on the Edit Toolbar to activate the editor, 
or use the Custom Crayons command in the Tools Menu. 
 

New Crayon Box 
 
In Paint-By-Number Artist, colors are grouped together in crayonboxes.  Click the New Crayon 
Box button to create a new box of crayons.  This button is in the section of the editor labeled 
Select Crayon Box. 



pbnArtist User’s Manual 
 

  
Page 60 

 
  

 
 

Crayon Box Name 
 
Enter a name for this crayonbox in the Crayon Box Name text entry box. 
 
 

Crayon Icon 
 
Select the icon to be used for these colors in the Crayon Icon list. 
 
 

Save Crayon Box Changes 
 
Save the crayonbox name and icon by clicking the button labeled Save Changes in the Edit 
Crayon Box section of the editor. 
 
 

New Crayon 
 
Create a new crayon by clicking the New Crayon button.  This button is in the section of the 
editor labeled Select Crayon(s). 
 
 

Copy Crayons From Another Box 
 
If you would like, you can also begin by copying crayons from one of the other crayonboxes.  
The crayons you copy will have the same names and colors as they did in the original box, but 
their icons will be replaced with the icon for this crayonbox. 
 
To do this, click the Copy From ... button.  This will open a new window that lets you select the 
other crayonboxes and check the crayons you want to copy. 
 
 

Select each crayon and edit 
 
You can specify the name, key and color for each crayon. 
 
Select one of the crayons in the Select Crayon(s) section, and then edit it using the commands 
in the Edit Crayon section. 
 
To specify the name, type a name in the box labeled Long Name. 
 
To specify a key, type a key in the box labeled Key.  The key is the number or abbreviation that 
will show up on your drawing every place where this crayon is to be used.  You may use a 
number or text for this key. 
 
If you would like, you can automatically assign numbers for these keys by pressing the Use 
Next Number button, or by waiting until you have created all crayons and then pressing the 
Renumber All button in the Select Crayon(s) section of the editor. 
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To specify a color for this crayon, press the Edit Color button, which will open the Color Editor.  
This is described in the next two pages.  You can specify a color by entering the color directly, 
or by sampling a color from a scanned image. 
 
When you are satisfied with this crayon, press the Save Changes button in the Edit Crayon 
section, and then continue with the next crayon. 
 
 

Re-arrange the crayons and crayonboxes 
 
If you would like to change the order in which crayons are listed, you may select individual 
crayons and then move them up or down using the arrow buttons in the Select Crayon(s) 
section. 
 
If you would like to change the order in which crayonboxes are listed, you may do the same 
thing in the Select Crayon Box section by selecting a crayonbox in the dropdown list, and then 
using the arrow buttons in this section to move the box up or down within the list. 
 
 

Finishing Up 
 
When you are done creating custom crayons, press the Close button at the bottom-right corner 
of the editor.  The crayons you have created will be added to the list in Step 1 of the Quickstart 
Panel.  They will be available whenever you run the program. 
 
This will run a process that profiles the crayons and prepares them for use.  Profiling your 
crayons may require a minute or so to complete. 
 
 

For more information 
 
Click Here for more detailed information about the Custom Crayons Editor. 
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Defining Colors with the Color Editor 

 

 
 
The Color Editor will open when you press the Edit Color button on the Custom Crayons Editor, 
described in the previous page in this manual.  This tool lets you define a color for each crayon, 
either by selecting the color, by entering its numerical value, or by sampling a color from a 
photograph. 
 

Selecting a color 
 
You can select a color by clicking on any of the pre-defined color boxes, or by clicking a color on 
the color wheel and vertical slider. 
 
The pre-defined color boxes provide commonly used colors and grayscales (including warm, 
neutral and cool grays).  If you have enabled the Show Popups command in the Help Menu, 
then you can see the names of these colors and grayscales by allowing the cursor to hover over 
each box. 
 
To use the color wheel and vertical slider, click an area on the color wheel to select the color 
value (hue) and saturation (richness), and move the slider to select the color's brightness.  You 
can use these in either order, but you will notice that when you click an area on the color wheel 
the entire vertical slider changes to show the entire range of brightnesses available. 
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When you have selected a color using either the pre-defined boxes or the color wheel and 
slider, the square color box will change to show you the selected color. 
 
The Color Editor's basic mode is described in more detail in the Reference Manual. 
 
 

Entering a color's numerical value 
 
To enter numerical values, you need to press the Advanced button.  The advanced mode allows 
you to enter numerical values.  It also allows you to use all of the colorspaces that are available 
in Paint-By-Number Artist. 
 
The Color Editor's advanced mode is described in more detail in the Reference Manual. 
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Sampling Colors from a Scanned Image 

 

 
 
You can also sample a color from a photograph or image that you have opened into pbnArtist. 
 
Prepare a page of color samples.  Use your crayons or other media to color swatches onto a 
sheet of paper.  Then use a computer scanner to scan this image into your computer, and open 
the scanned image into pbnArtist, using the New Project command in the File Menu. 
 
Open the Custom Crayons Editor as described previously, and when you have a new crayon 
that is ready to be edited, click the Edit Color button to open the Color Editor. 
 
Arrange the windows so you can see both the Color Editor and the Main Program window.  
Move the cursor into the Main Program window.  When it is over your scanned image it will 
change to the pixel sampler image shown here. 
 
Move the pixel sampler over the desired color sampler, and click the mouse.  The sampled color 
will be selected in the Color Editor. 
 

 
 
The actual pixels being sampled are indicated by the circle in the Pixel Sampler.  The color 
selected will be the average color from all of these pixels.  You can change the size of the 
sampling circle by adjusting the horizontal Sampler slider in the Color Editor. 
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Sharing Custom Crayons with Other Users 

 

 
 
 
After you have created custom crayons, you may wish to save them to an external file and 
share them with your friends. 
 
 
 

Exporting Custom Crayons 
 
To save custom crayons to an external file, press the Export To File button in the Custom 
Crayons Editor, or use the Export Custom Crayons command in the File Menu. 
 
This will open the window shown above.  Select which crayonboxes to include.  You may 
include any number of crayonboxes in an external file.  Only custom crayonboxes are available; 
system crayons are not available for exporting (they can, however, by copied into a custom 
crayonbox). 
 
After selecting the crayonbox(es) to include, press the Continue button.  This will open a window 
that allows you to navigate to a desired folder on your computer and save the file. 
 
Crayonbox files are saved with the extension .pbx added to the file name. 
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Importing Custom Crayons 
 
To add crayonboxes from an external file, press the Import From File button on the Custom 
Crayons Editor, or use the Import Custom Crayons command in the File Menu. 
 
This will open a window that allows you to navigate to a desired folder on your computer and 
open a crayonbox file.  By default, crayonbox files have the extension .pbx added to the file 
name. 
 
Select the desired file.  All crayonboxes in this file will be added to the list of crayonboxes shown 
in Step 1 of the Quickstart Panel.  The imported crayons will continue to be available every time 
you use Paint-By-Number Artist, unless you eventually remove them from the list. 
 
 

Removing Custom Crayonboxes 
 
If you decide that you no longer wish to use a custom crayonbox, you may remove it by using 
the Custom Crayons Editor.  Be careful if you decide to do this -- it can not be undone. 
 
Open the Custom Crayons Editor by pressing the Custom Crayons button on the Edit Toolbar, 
or by using the Custom Crayons command in the Tools Menu. 
 
Use the dropdown list in the Select Crayon Box section to select the crayonbox that you wish to 
remove. 
 
Press the Remove Box button.  You will be asked to confirm this operation.  Be careful -- once 
you do this it can not be undone. 
 
Only custom crayonboxes can be removed.  System crayonboxes can not be removed. 
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Changing the Crayon Assigned to a Patch 

 
You can use the Pixel Sampler tool and the Patch Crayon Changer to examine and change 
crayons that have been assigned to individual patches within your drawing.  You can also 
modify individual stitches in a cross stitch pattern with these tools. 
 

Examining Pixel Colors with the Patch Sampler 
 
Clicking the Pixel Sampler button (this is the button with an eyedropper for its icon, as shown 
above) opens the Pixel Sampler window, shown here.  This tool is described in more detail 
here. 
 

 
 
The Patch Sampler can be accessed in the Tools Menu, on the Edit Toolbar, or by pressing the 
Edit Drawing button in Step 3 of the Quickstart Panel. 
 
You can used the sampler to see the color of an individual pixel or a group of pixels by clicking 
on your drawing.  The window that appears will show both the actual color of the pixel and the 
crayon assigned to that pixel.  This window will also allow you to change the sampling size, so 
the tool will select either an individual pixel or a circular group of pixels.  When a group is 
selected, the color displayed will be the average color of all of the selected pixels. 
 
The sampling window also allows you to activate the Patch Crayon Changer. 
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Changing Crayons with the Patch Crayon Changer 
 
Clicking the Patch Crayon Changer button (this is the button with a crayon for its icon, as shown 
above) opens the Patch Crayon window, shown here.  This tool is described in more detail here. 
 

 
 
Select whether you would like to change a single patch, all patches that use this crayon, or an 
individual stitch (in cross stitch view). 
 
Move the cursor over the desired color in your drawing.  Click on that point to change the crayon 
to the selected crayon. 
 
The patch will change to the crayon highlighted in the crayon list.  You can also reset the patch 
to its original crayon, and you can set it to be blank (no crayon). 
 
You can also quickly sample a patch by shift-clicking the point (holding down your keyboard's 
SHIFT button while clicking).  Shift clicking on a patch will cause that patch's crayon to be 
selected in the tool, and then you can immediately assign that crayon to other patches. 
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How to Change the Cross Stitch Symbol 
Collection 

 

 
 
Accessing the cross stitch symbol collection will open the window shown above.  In this window 
you can select the actual symbols that will be assigned to the stitches in your project.  These 
symbols come from the character fonts that are available in your computer. 
 
 

Activate the editor 
 
There are three ways that you can access the cross stitch symbol collection.  You can press the 
symbol button in the edit toolbar (this is the button with an Ace for its icon, as shown above).  
You can also select Cross Stitch Symbols from the Tools menu, or you can press the Tools 
button in the Step 3 -- Cross Stitch tab on the Quickstart panel. 
 
 

Using the editor 
 
Symbols will be assigned to colors in the order they are listed in this collection.  The symbol at 
the top of the list will be assigned to the most frequently used color, or floss, in your project. 
 
The left side of this window allows you to examine each font type that is available in your 
computer.  Some font types are divided into multiple groups.  If that is the case for the font you 
are examining, the number of groups available will be displayed along with the currently 
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selected group number. 
 
The right side of this window shows the symbols that you have included in your font collection. 
 
To add a symbol to your collection, select the desired symbol on the left side of this window, 
and click the right arrow (-->) in the middle of the window. 
 
Each symbol will be added at the currently selected location.  If you would like to move a symbol 
up or down within your collection, select the symbol and click either the up arrow or the down 
arrow. 
 
If you would like to remove a symbol from your collection, select the symbol (in the right side of 
this window) and click the left arrow (<--). 
 
You can also set the size of all of the symbols in the collection.  The symbol size will affect how 
large your cross stitch pattern is when printed on paper.  For very large projects, you may wish 
to use a smaller font size so that the pattern can be printed on a single page.  In other cases, 
you might wish to use a larger font size to make the pattern more readable, and to make it 
easier for a person to count stitches. 
 
You can also select whether the symbols should be printed using regular, bold, or italic type.  
(Bold and italic options are not available for all font types, so these settings might not be applied 
to your entire collection). 
 
To have some fun, insert additional character fonts onto your computer and add them to your 
symbol collection.  There are hundreds of symbol fonts available on the internet, and many of 
them are available for free.  To find new fonts, search the internet using the search term 
"dingbat fonts".  Follow the provider's directions to insert new fonts onto your computer, and 
then use this tool to add them to your cross stitch symbol collection. 
 
 

 
  



pbnArtist User’s Manual 
 

  
Page 71 

 
  

How to get Best Results 
 
Optimizing the Program Settings 
 

How to Select the Photo Type  
 

 
 
The line detection algorithm that Paint-By-Number Artist uses can be fine-tuned to work with 
different types of photographs. 
 
Normally, you will obtain best results using the setting labeled Digital Camera.  This setting is 
designed to work with photograph files that come directly from a digital camera, and with scans 
of photographs that are printed on film or photographic paper.  However, some types of images 
will work better using the other choices. 
 
Use the Scanned Print when scanning photographs that were printed with a computer printer. 
 
Use the Newsprint setting when using photographs that are printed on newsprint (also called a 
halftone print). 
 
Use the Graphics setting when you are working with graphics images, which you have drawn 
using an illustration or presentation type of program. 
 
You can also experiment with the settings.  Here are some more suggestions: 
 
Processing may take a long time if you use the Graphics setting on photographs, but it might be 
worth the wait.  Graphics images typically have sharp lines and corners, so the program needs 
to analyze them in much more detail (the other settings will round the corners of graphics 
images).  But these images also have less detail, so the program can afford to take more time 
analyzing them.  Photographs have a lot more detail than graphics images, which is why this 
setting may take longer when used on photographs. 
 
Using the other settings on graphics images will result in rounded corners and edges that may 
be too soft. 
 
Some photographs have a softer focus, which is sometimes used to increase the emotional 
impact of a photograph.  This type of photograph may work better using either the Scanned 
Print  or Newsprint setting, so you can also try these settings.  These settings don't generally 
work as well as the Digital Camera setting with sharply focused photographs, but you may find 
that the result is more pleasing for photographs with a soft focus or a hazy appearance. 
 
You can also experiment with the custom setting.  pbnArtist uses a softening filter (technically 
called a gaussian filter) to process each photograph.  You can adjust the amount of softening 
and the step size that this filter uses, in order to fine-tune your drawing, and you can also see 
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the values used for the other presets. 
 
 
 
 
 

How to Select Which Crayons To Include 

 

You can normally allow pbnArtist to select the crayons to include in your drawing.  However, 
there are times when you may want to select the crayons yourself.  The two pictures here show 
an example of such a case.  The picture on the left shows an original photograph of a black-
collared swan.  The picture on the right shows the crayons pbnArtist has decided to assign, 
when limited to 10 crayons. 
 

 
 
Sometimes, the most important part of your photograph will be so small that its color doesn't 
make it to the Top 10 list!  (or whatever number of crayons you are hoping to use).  If that 
happens, you may find that your favorite color in the photograph doesn't even show up as one 
of the crayons used for the drawing. 
 
This is shown in the above example.  The reddish color on the bridge of the swan's beak takes 
up an area that is less than 1% of the entire picture.  In this example, that amount is so low that 
pbnArtist didn't even select its color as one of the crayons to include in the picture. 
 
However, we can fix the problem manually. 
 
Select the Photo view in Step 3 on the QuickStart panel, and then return to the Step 1 tab.  
Select the Crayons tab, and check the Show Preview checkbox.  We see the view shown here: 
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With the preview turned on, we see that, as before, pbnArtist is using a shade of brown for the 
swan's beak. 
 
In the list of crayons, scroll down until you find a reddish crayon.  In this example, we see 
Mauve as the first red shade listed, (and we see that pbnArtist is saying that this crayon applies 
to less than 1% of the picture's area).  Check the checkbox next to the Mauve crayon to force 
pbnArtist to include that crayon. 
 
(Or if you prefer, experiment with other shades of red.  For this photograph, brick red also gave 
a nice result). 
 
The preview now shows that Mauve will be applied to the swan's beak, giving an improved 
match to the color in the original photograph. 
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Editing Your Original Photograph 
 
 

How to Change the Image Resolution 
 
 

 
 
One more technique you can use to improve the quality of your paint-by-number drawings is to 
change the resolution of your photograph.  This is the number of pixels used to represent your 
photo.  Changing this value can sometimes improve the quality of the lines in your drawing. 
 
The resolution can be changed using the Image Size command in the File Menu.  You can 
change this value by adjusting either the width or height of the picture in pixels, or by entering a 
total number of megapixels.  (When you enter a total amount, it may be necessary for the 
program to adjust the number slightly so that the ratio of width to height doesn't change). 
 
You will usually obtain best results using a total value between 1 and 5 MegaPixels.  Larger 
values will cause the program to run more slowly, and values above 10 MegaPixels will usually 
be unnecessary. 
 
This window can also be used to specify the size of drawing views, in inches or centimeters.  
You may select a size that is larger than a single sheet of paper.  When you do this, drawings 
will automatically be printed across multiple sheets of paper. 
 
Sometimes it is desirable to save a drawing view as a graphics file but to have it split across 
multiple files, so that the saved files will be identical to large views that were printed across 
several pages.  Clicking the Split Saved Graphics ... checkbox will automatically save views into 
multiple graphics files. 
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Altering Your Photograph 

 

Paint-By-Number Artist provides several tools to make alterations to your photograph.  These 
techniques can make considerable improvements to your final drawing because you can 
emphasize the important areas in your picture while removing detail from the less important 
parts. 
 
The tools that are available include cut, copy, crop and paste, as well as brush and bucket 
tools.  Use the cut, copy, crop or paste commands to change your photograph's size and aspect 
ratio, as well as removing the less important parts of the photo.  Use the brush and bucket tools 
to change colors, soften and enhance parts of the photo. 
 
All of these tools are described in more detail in the Reference Manual. 
 

Cut, Copy and Crop Tools 
 
Use these tools to remove or copy portions of your photograph.  The cut tool will replace a 
rectangular region with white space, and the crop command will reduce the size of your 
photograph.  The Copy command can copy part of your photograph onto another part, or into 
another software program. 
 
These tools are available from the Standard Toolbar, the Edit Menu, or the Edit Photo button in 
Step 1 of the Quickstart Panel. 
 
To use any of these tools, begin by selecting the tool.  Drag the cursor across your photograph 
to select a rectangular portion of the photo.  When you release the mouse button a rectangle will 
appear on the photo with small selection squares at its corners and sides.  You may drag any 
one of these squares to adjust the size of the selection rectangle, or you may drag the larger 
square to move the entire rectangle. 
 
To create a square selection angle, hold down the shift key when you make the initial selection.  
To use a predefined aspect ratio (ratio of width to height or height to width), use the Aspect 
Ratio settings that are available in the Photo Tool Settings command in the Tools Menu, or use 
the Brush and Bucket Settings button on the Edit Toolbar. 
 
When you are satisfied with the selection, move the cursor to the center of the rectangular 
selection area and click the mouse.  Or if you change your mind and decide to cancel the 
operation, move the cursor outside of the selection area and click the mouse. 
 

Paste Tool 
 
After you have cut or copied a section of the photograph, you may paste it onto another part of 
the photo.  The paste command is available in the Edit Menu or on the Standard Toolbar. 
 
This command operates similarly to the cut, copy and crop commands.  When you activate the 
paste command, a preview of the pasted image will appear on your photograph, and it will be 
surrounded by a selection area rectangle.  You may move and resize this image before 
finalizing the operation. 
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When you are satisfied with the size and location of the pasted image, move the cursor to the 
center of the preview and click the mouse.  If you change your mind and wish to cancel the 
operation, move the cursor outside of the preview and click the mouse. 
 

Brush and Bucket Tools 
 
You can use the brush and bucket tools to paint a color on top of your photograph, to soften the 
focus in parts of the photograph, or to enhance the brightness, contrast and saturation in parts 
of the photograph. 
 
The brush tools allow you to modify the photo by stroking over parts of it, similar to using a paint 
brush.  As you stroke the photo, you will see the modification taking place. 
 
The circle on the cursor indicates the region that will be affected by the operation -- you can 
change the size of this circle in the settings for this tool.  The brush tool also includes a feather 
option which reduces the affect along the edges of the stroke. 
 
If you are moving the brush faster than the program can process the operation, you will see a 
dotted line that traces your brush stroke, followed by the operation taking place.  If the program 
is unable to keep up with you, don't worry -- the cursor will change to a wait cursor, which looks 
like a sand-filled hourglass.  This indicates that the program is requesting you to wait for a few 
seconds while it catches up with you. 
 
The bucket tools work similarly to the cut, copy and crop commands.  With the bucket tools, you 
first select a rectangular selection area, adjust its size and position, and then fill the section with 
the desired operation.  You complete the operation by clicking the mouse in the center of the 
selection area, or you can cancel by clicking the mouse outside of the selection area. 
 
The bucket tool also includes a feather operation. 
 
The values for color and amount of softening or enhancing can be accessed and set in the 
Brush and Bucket Settings command which you can access within the Edit Menu, on the Edit 
Toolbar, or by clicking the Edit Photo button in Step 1 of the Quickstart Panel. 
 
For your convenience, the symbols that identify the buttons on the Edit Toolbar are shown here: 
 

  Paint Brush and Paint Bucket (adds color) 
 

  Soften Brush and Soften Bucket (softens focus) 
 

  Enhance Brush and Enhance Bucket (adjusts brightness, contrast and saturation) 
 

  Brush and Bucket Settings 
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Editing and Printing Your Final Drawing 

 

Altering the Final Drawing 

 

pbnArtist includes tools that allow you to make alterations to your drawing after your photograph 
has been processed into a drawing.  These tools allow you to change the crayons that are 
assigned to individual patches of the drawing, draw additional sketch lines onto the drawing, or 
erase sketch lines from the drawing. 
 
All of these tools are described in more detail in the Reference Manual. 
 
 

  Examining Pixel Colors with the Patch Sampler 
 
Activating the Pixel Sampler opens the Pixel Sampler window, shown here. 
 

 
 
The Patch Sampler can be accessed in the Tools Menu, on the Edit Toolbar, or by pressing the 
Edit Drawing button in Step 3 of the Quickstart Panel. 
 
You can used the sampler to see the color of an individual pixel or a group of pixels by clicking 
on your drawing.  The window that appears will show both the actual color of the pixel and the 
crayon assigned to that pixel.  This window will also allow you to change the sampling size, so 
the tool will select either an individual pixel or a circular group of pixels.  When a group is 
selected, the color displayed will be the average color of all of the selected pixels. 
 
The sampling window also allows you to activate the Patch 
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  Changing the Crayon assigned to a Patch 
 
Clicking the Patch Crayon Chooser button (shown above) opens the Patch Crayon window, 
shown here. 
 

 
 
Select whether you would like to change a single patch, all patches that use this crayon, or an 
individual stitch (in cross stitch view). 
 
Move the cursor over the desired color in your drawing.  Click on that point to change the crayon 
to the selected crayon. 
 
You can also quickly sample a patch by shift-clicking the point (holding down your keyboard's 
SHIFT button while clicking).  Shift clicking on a patch will cause that patch's crayon to be 
selected in the tool, and then you can immediately assign that crayon to other patches. 
 
 

  Adding Sketchlines with the Sketchline Pencil 
 
The Sketchline Pencil allows you to draw additional sketchlines onto your drawing.  It can be 
accessed in the Tools Menu, on the Edit Toolbar, or by pressing the Edit Drawing button in Step 
3 of the Quickstart Panel. 
 
To use this tool, select the Color By Numbers view, the Line Drawing view, or the Color Drawing 
view of your paint-by-number drawing.  You can make this selection in the View Menu or in Step 
3 of the Quickstart Panel. 
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Activate the tool.  You use this tool simply by stroking over the drawing. 
 
There are no settings for this tool.  The lines that are added will have the same color and width 
as all sketchlines, which can be changed by pressing the Line Style button next to the Sketch 
Mode radio button in Step 3 of the Quickstart Panel, or by using the View Settings command in 
the View Menu. 
 
 

  Removing Sketchlines with the Sketchline Eraser 
 
The Sketchline Eraser allows you to remove sketchlines onto your drawing.  It can be accessed 
in the Tools Menu, on the Edit Toolbar, or by pressing the Edit Drawing button in Step 3 of the 
Quickstart Panel. 
 
To use this tool, select the Color By Numbers view, the Line Drawing view, or the Color Drawing 
view of your paint-by-number drawing.  You can make this selection in the View Menu or in Step 
3 of the Quickstart Panel. 
 
Activate the tool.  You use this tool simply by stroking over the drawing.  The tool will erase any 
sketchlines that are within the circular area on the tool's cursor image.  You can change the size 
of this circle within the Eraser Settings. 
 
The settings for this tool can be changed by using the Drawing Tool Settings command in the 
Tools Menu, by pressing the Edit Drawing button in Step 3 of the Quickstart Panel, or by 
pressing the Eraser Settings button on the Edit Toolbar. 
 
For your convenience, the Eraser Settings button is shown here: 
 

  Eraser Settings 
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Printing Tip:  Papers for Crayons and Paints 
 

If you are printing a drawing that will be colored using crayons, pencils or other art media, you 
may encounter a problem.  Most papers that are designed for computer printers are coated with 
a material that gives them a shiny finish.  This is desirable for most types of printouts, but it can 
prevent drawing materials from adhering to them.  You might notice that crayons, for example, 
slide off of this finish without leaving much color. 
 
Art papers, on the other hand, are designed to work well with these drawing media.  Art papers 
have a coarse finish, which provides a so-called bite that causes these colors to adhere. 
 
But art papers, unfortunately, are usually cut to sizes that don't fit computer printers, and they 
may be able to damage your printer.  Especially stiff or thick papers might damage the rollers 
that push paper through your printer.  The lack of finish on these papers may cause printer inks 
to leave the paper and stay on the rollers, causing smears on future printouts. 
 
There are two options you may wish to try.  For coloring pages, using crayons,  we recommend 
using 100% Cotton Resume Paper, that is specifically designed for inkjet or laser printers.  This 
type of paper has a coarser finish that will adhere well to coloring materials, and it will work well 
with your home computer printer.  100% Cotton Resume Paper is produced by several well-
known paper manufacturers, and is available at most office supply stores or college 
bookstores.  Check the label, and make sure that the paper you are using is inkjet printer 
compatible, or laser printer compatible, depending on the type of printer you are using. 
 
For paintings, purchase a tablet of artist's paper that is designed specifically for the type of paint 
you will be using.  This paper will probably be two large for your printer, but you can easily cut it 
to a smaller size.  In most cases, it will only be necessary to trim it to the correct width; the 
longer length should still work with most printers.  Test the result -- the ink or toner your printer 
uses may not adhere perfectly to this type of paper, but it should be good enough to enable you 
to complete your painting. 
 
But be careful when using these papers.  Some printers are not designed to use thick papers, 
and other printers, while compatible, may still require you to use a special "thick paper" setting.  
Incorrectly using thick paper can, in some cases, cause the printer's rollers to wear-out 
prematurely, preventing them from working properly with thinner papers.  Check your printer's 
user manual before using thick papers. 
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Photography Tips 

 

Types of Photos that Work Best 
 

Paint-By-Number Artist will work with all types of digital photographs.  However, it is designed to 
work best with photographs of people, animals and plants.  Photographs of scenery will also 
work well if the scenery has a clearly defined subject.  Paint-By-Number Artist is intended to be 
used to let you preserve your most important memories, and that is why it is targeted to these 
types of photographs. 
 
Choose photographs that have a clearly defined subject.  This means that the most important 
part of the photo, which is the part you want people to notice, should fill most of the photograph, 
and not be distracted by other items in the photograph. 
 
When you are using a photograph of a person or an animal, the eyes are almost always the 
subject.  This is because we communicate with our eyes.  When we talk to each other, we 
watch each others' eyes.  In photography, this means that the eyes should be clearly in focus, 
and the face should fill enough of the picture so that you can easily see the eyes. 
 
When you are using a photograph of plants, try to pick one plant in a group, or one part of a 
plant, that you want to use as the subject.  This part of the photograph should stand out from the 
rest, by being larger, by being brighter, or by using compositional techniques to direct attention 
to that part of the picture. 
 
When you are using a photograph of scenery, use the same idea to pick one part of the scenery 
as the most important part.  This might be one mountain or hill in a group of hills, one tree in a 
group of trees, the sun in a photograph of the sunset, or other items.  Again, this part should 
stand out, by being larger or brighter, or by using compositional techniques to attract attention to 
it. 
 
In Paint-By-Number Artist, photographs with a clearly defined subject should produce better 
paint-by-number drawings, as the subject matter will then also stand out in the drawing.  You 
can use the tools and techniques offered in earlier sections to help emphasize these parts of 
your drawings.  For example, you may want to use the Sketchline Eraser to erase parts of the 
drawing that are not part of the subject, or you may want to use the Sketchline Pencil to add 
detail to the subject. 
 
 

Composition Tips 

 

When you take photographs that you intend to use with Paint-By-Number Artist, you will get 
best results if you try to emphasize the subject in the photograph. 
 
The subject is that one part of the photograph that you consider to be the most important.  It is 
the item that attracted your attention and motivated you to take the picture. 
 
Sometimes we assume everybody else will notice the same thing that we noticed.  But that is 
not usually the case.  Photographs are two-dimensional and flat, and they make it difficult for 
other people to notice and focus on the same items that we noticed in real-life. 
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So here are some tips. 
 
First of all, identify the subject.  This means you should really think about it.  What is the one 
thing that caught your attention?  Is it enough to say that I am photographing a person?  Or am I 
really photographing her eyes, her hair, her cute nose? 
 
Arrange your photo to attract attention to this one thing.  (And to flatter it without embarrassing 
it). 
 
Experiment with placing the subject in different locations on the picture.  Usually, the center of 
the picture is the worst place to locate your subject.  Centering your subject can be distracting, 
and can add an uncomfortable feeling to your photo.  It is not clear why this makes us 
uncomfortable -- it has something to do with the psychology of the eyes, if the term can be used 
that way. 
 
Instead, place your subject off-center.  Try dividing your photograph into three vertical and three 
horizontal sections, kind of like a Tic-Tac-Toe game.  Place the subject at one of the places 
where the cross-lines intersect. 
 
Look for lines in your photograph, and use these lines to point toward the subject.  Lines may be 
straight or wavy.  In fact, wavy lines can add interest.  These lines might be the shape of a tree, 
a road or a river, the sides of a building, the wings of a bird, or other items. 
 
And look for lines that can frame or surround your subject.  Framing a subject can add interest 
and can draw attention to your subject. 
 
Use highlights and colors to help emphasize the subject.  Our eyes are naturally drawn toward 
brighter colors, so take advantage of this. 
 
Finally, think of the way we use our eyes in day-to-day life.  If you read the english language, 
then you normally read from left-to-right, and your eyes habitually move in this direction.  
Experiment with items that point in opposite direction -- forcing the eyes to do something new, 
or forcing them to stop when they reach the subject. 
 
Anyway, those are just a few suggestions to help you create great drawings with Paint-By-
Number Artist.  Sometimes these suggestions will help.  But they are not rules -- sometime 
doing the exact opposite and breaking the rules will give you the best result.  So above all, 
experiment and have fun! 
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Part 3:  Reference Manual 

 

 
Summary 

 

The rest of this user manual is intended for people who want detailed information about the 
program features.  It contains the following sections: 
 
Main Menu  

 File Menu  

 Edit Menu  

 Tools Menu  

 View Menu  

 Help Menu 
 
Quickstart Panel  

 Summary   

 Step 1  

 Step 2  

 Step 3 
 
Toolbars  

 Standard Toolbar  

 Edit Toolbar 
 
Editing Tools 

 Image Size Window  

 Photo Edit Tools 

 Drawing Edit Tools  

 Patch and Pixel Sampler  

 Patch Crayon Changer  

 Custom Crayons Editor  

 Color Editor:  Basic View 

 Color Editor:  Advanced View 

 Cross Stitch Symbol Collection 
 
Colorspaces  

 How Paint-By-Number Artist uses Colorspaces  

 RGB Colorspace  

 HLS Colorspace  

 LAB Colorspace  

 Other Colorspaces 
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Main Menu 
 
 

File Menu 

 

 
 
These are the commands that are available in the File Menu. 
 

New Project From Photograph 
 
The New Project From Photograph command creates a new project and allows you to open an 
image file to place into this project. 
 
The command opens a window that lets you navigate to and select an image file.  The directory 
will initially be the same directory you have previously used for opening or saving graphics 
images.  The file type is set to All Image Files but you can also specify individual graphics 
formats. 
 
This command is identical to the New button in Step 1 of the Quickstart Panel, and the Create 
New Project button on the Standard Toolbar. 
 

Open Project 
 
The Open Project command opens an existing project file. 
 
The command opens a window that lets you navigate to and select a project file.  The directory 
will initially be the same as the directory you have previously used for opening or saving project 
files.  The file type is set to PbnArtist project files, which have the extension .pbn added to their 
file name. 
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This command is identical to the Open button in Step 1 of the Quickstart Panel, or the Open 
Existing Project button on the Standard Toolbar. 
 
 

Close Project 
 
This command closes the current project. 
 
If the project file has not been saved, or if changes have been made since the last time it was 
saved, the program will ask if you want to save the file.  If this is the first time the project has 
been saved, a window will open that allows you to navigate to a folder and specify a name for 
the file.  Project file names end with the extension .pbn. 
 
 

Import Custom Crayons 
 
This command allows you to read crayons from an external file.  The command will open a 
window that allows you to navigate to a desired folder on your computer and open a crayonbox 
file.  Crayonbox files may hold a single crayonbox or multiple crayonboxes.  These files have 
the extension .pbx added to the file name. 
 
All crayonboxes in the selected file will be added to the list of crayonboxes shown in Step 1 of 
the Quickstart Panel.  The imported crayons will continue to be available every time you use 
Paint-By-Number Artist, unless you eventually remove them from the list. 
 
This command is identical to the Import From File button in the Custom Crayons Editor. 
 
 

Export Custom Crayons 
 
This command allows you to save custom crayons to an external file.  The command will open a 
window that asks you to select which crayonboxes to include.  You may include any number of 
crayonboxes in an external file.  Only custom crayonboxes are available; system crayons are 
not available for exporting (they can, however, by copied into a custom crayonbox). 
 
After selecting the crayonbox(es) to include, press the Continue button.  This will open a window 
that allows you to navigate to a desired folder on your computer and save the file.  Crayonbox 
files are saved with the extension .pbx added to the file name. 
 
This command is identical to the Export To File button in the Custom Crayons Editor. 
 
 

Image Size 
 
This command lets you change the resolution (number of pixels) of your photograph.  You may 
change either the height, width, or total number of pixels -- the other values will change 
accordingly to keep the ratio between height and width constant.  (Sometimes you may notice 
that the total value changes slightly to accommodate this constant ratio requirement). 
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You will usually obtain best results using a total value between 1 and 5 MegaPixels.  Sizes 
outside of this range might create drawings that don't look as good as possible, and larger 
values will also cause the program to run slowly. 
 
The size setting only affects the size of the photograph within your project.  It does not affect 
your original photograph file. 
 
NOTE:  Only the photograph size will be changed.  The size of the drawing views are not 
affected by this setting -- they are controlled by the page size used for printing. 
 
 

Save Project 
 
This command saves your project file.  If this is the first time you have saved the project, then 
the command automatically runs the Save Project As ... command, which asks you to provide a 
file name and location before saving the file. 
 
 
This command is identical to the Save Project button on the Standard Toolbar. 
 
 

Save Project As ... 
 
This command saves your project to a location and name that you specify. 
 
The command opens a window that allows you to navigate to a desired folder and specify a 
name for the file.  The window will initially open to the last location where you stored a project 
file.  Project file names end with the extension .pbn. 
 
 

Save Graphics As ... 
 
This command saves the current view as a graphics file.  This is different than saving your 
entire project -- only the current view will be saved.  Doing this allows you to save the view in 
formats that can be used by other computer programs. 
 
The command opens a window that allows you to navigate to a desired folder and specify a 
name for the file.  The window will initially open to the last location where you stored a graphics 
file.  This might be different from the location used for project files, making it easier for you to 
store project files and graphics files in separate locations if you desire. 
 
To specify the view that you are saving, select the view either in Step 3 of the Quickstart Panel, 
or in the View Menu.  The view being saved will be the same as the view you see displayed in 
the project workspace. 
 
By default, graphics files will be given a name that begins with either the project name or the 
original photo name, followed by the name of the view, followed by an extension that indicates 
the file format. 
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View names that are used are: 
 

 _PBN 
The numbered paint-by-number drawing, ready for painting or coloring 
 

 _LineDrawing 
The un-numbered line drawing, ready for painting or coloring 
 

 _ColorDrawing 
The drawing with all colors filled in 
 

 _Key 
The list of paints or crayons used in you paint-by-number project 
 

 _CrossStitch 
The cross stitch or needlepoint pattern 
 

 _csKey 
The list of flosses used for your cross stitch or needlepoint pattern 
 

 _Photo 
The original photograph 
 

 
Possible file formats are: 
 

 .jpg 
JPEG format 
 

 .bmp 
Bitmap format 
 

 .gif 
GIF format 
 

 .png 
Ping format 
 

 .tif 
Tiff format 
 

 .wmf 
Windows Metafile format 
 

 .emf 
Extended Windows Metafile format 
 

 
In general, PNG format will give the best result for the drawing and color key views, and JPEG 
will give best results for the photo view. 
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Page Settings 
 
This command allows you to change the size of the paper being used for printing, its orientation 
(portrait or landscape) and margins on the sides of the page. 
 
 

Print Preview 
 
This command displays a preview of your printout, giving you an on-screen view that shows 
how the printout will look on paper. 
 
 

Print 
 
Sends the current view to the printer. 
 
This command is identical to the Print Current View button on the Standard Toolbar. 
 
 

Exit 
 
Closes and exits the program.  If a project is open, you will be asked to confirm that you want to 
close the project before exiting.  If the project has not been saved, then you will also be asked to 
save the project before exiting. 
 
This command is identical to the big red X in the upper right corner of the program's main 
window. 
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Edit Menu 

 

 
 
These are the commands that are available in the Edit Menu. 
 

Undo 
 
Many of Paint-By-Number Artist's commands can be undone.  For example, if you are using the 
Paintbrush to paint a color onto your photograph, and you change your mind, you can remove 
individual brush stroke's by running this command. 
 
This command will indicate if it is available or not, by whether its color is black (available) or 
gray (unavailable). 
 
This command is identical to the Undo button on the Edit Toolbar. 
 

Redo 
 
If you have used to the Undo command to undo an operation, you can re-apply the operation by 
using the Redo command. 
 
This command will indicate if it is available or not, by whether its color is black (available) or 
gray (unavailable). 
 
This command is identical to the Redo button on the Edit Toolbar. 
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Cut 
 
The Cut command removes a rectangular portion of your image and replaces it with a white 
rectangle.  The cut portion is available for a later Paste operation.  The Cut command may be 
used on either the Photograph or the Drawing views. 
 
To use this command, select the command and then drag the cursor across the rectangular 
region that you wish to cut.  A selection rectangle will be drawn that indicates the region to be 
cut. 
 
The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
 
You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
 
You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the cutting tool without using it, click the Cut command a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Cut 
command.  When used this way, the cut operation will happen immediately. 
 
This command is identical to the Cut button on the Standard Toolbar and the Cut button in the 
Photo Edit Tools.  When the tool is active, a box will surround its button on the Standard 
Toolbar, and a check will appear next to the command on the Edit Menu. 
 

Copy 
 
The Copy command copies a rectangular portion of your image and replaces it with a white 
rectangle.  The copied portion is available for a later Paste operation, and may also be used to 
copy the current view into another computer program.  The Copy command may be used on 
either of the Photograph, Drawing, or Color Key views. 
 
To use this command, select the command and then drag the cursor across the rectangular 
region that you wish to copy.  A selection rectangle will be drawn that indicates the region to be 
copied. 
 
The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
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You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
 
You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the copy tool without using it, click the Copy command a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Copy 
command.  When used this way, the copy operation will happen immediately. 
 
This command is identical to the Copy button on the Standard Toolbar and the Copy button in 
the Photo Edit Tools.  When the tool is active, a box will surround its button on the Standard 
Toolbar, and a check will appear next to the command on the Edit Menu. 
 

Paste 
 
The Paste command pastes an image that you have previously cut or copied, onto your 
photograph.  The Paste command may only be used on the Photograph view.  Pasting is not 
available for any of the Drawing views. 
 
To use this command, begin by using either the Cut command or the Copy command, or you 
may also use the equivalent of these commands in another computer program.  Click the Paste 
command, and a preview of your cut or copied image will appear over a rectangular portion of 
your photograph, with a selection rectangle drawn around it. 
 
You may adjust the size of the image by dragging any of its sides or corners to a desired 
location, or you may move the entire image by dragging its upper-left corner.  Hold down the 
Shift key while you are adjusting the image's size to maintain its original aspect ratio. 
 
When you are satisfied with the image's size and location, move the cursor to the interior of the 
selection rectangle and click the mouse. 
 
If you would like to cancel the operation, move the cursor outside of the rectangle and click the 
mouse.  You can also cancel the operation by clicking the Paste command a second time.  The 
preview of the copied image will disappear. 
 
This command is identical to the Paste button on the Standard Toolbar and the Paste button in 
the Photo Edit Tools.  When the tool is active, a box will surround its button on the Standard 
Toolbar, and a check will appear next to the command on the Edit Menu. 
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Select All 
 
This command is useful when used with the Cut command or the Copy command.  To select the 
entire image, click the Select All command.  To cancel the selection, click the command a 
second time. 
 
This command is identical to the Select All button on the Standard Toolbar. 
 
 

Crop 
 
The Crop command resizes your image and removes anything that is outside of the rectangular 
selection region.  The Crop command may only be used on the Photograph view.  Cropping is 
not available for any of the Drawing views. 
 
To use this command, select the command and then drag the cursor across the rectangular 
region that you wish to cropped.  A selection rectangle will be drawn that indicates the region to 
be cropped. 
 
The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
 
You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
 
You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the cropping tool without using it, click the Crop command a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Crop 
command.  When used this way, the crop operation will happen immediately. 
 
This command is identical to the Crop button on the Standard Toolbar and the Crop button in 
the Photo Edit Tools.  When the tool is active, a box will surround its button on the Standard 
Toolbar, and a check will appear next to the command on the Edit Menu. 
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Process Photograph 
 
This command processes your photograph into a paint-by-number drawing.  Click it when you 
are satisfied with your photograph or any changes you have made to the photograph or any of 
the settings. 
 
This command is identical to the Run button in Step 2 of the Quickstart Panel, and the Process 
Photo button on the Edit Toolbar. 
 
 

Cancel Process 
 
This command cancels the Process Photograph command while it is running, in case you have 
a reason to cancel the process.  Click it once while the process is running, and wait for the 
process to stop. 
 
This command is identical to the Cancel button in Step 2 of the Quickstart Panel, and the 
Cancel button on the Edit Toolbar. 
 
 

Process Settings 
 
This command allows you to change the setting listed below.  This setting can also be changed 
in Step 1 of the Quickstart Panel. 
 

 Photograph Type 

This command lets you set the photograph type, by selecting one of the displayed options.  
The options are Sharp Graphics for an image created by a drawing program, Sharp Photo 
for a sharply focused photograph, and Medium Photo, Soft Photo and Hazy Photo for 
photographs that were taken using soft focus effects or that were taken under hazy or foggy 
conditions. 

In most cases you will get best results using the Sharp Photograph setting, but you may 
wish to experiment with the other options. 

This command is identical to the Photograph Type selection slider in Step 1 of the 
Quickstart Panel. 
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Tools Menu 

 

 
 
These are the commands that are available in the Tools Menu. 
 
 

Custom Crayons 
 
pbnArtist allows you to manage the colors that are included in your drawings.  Colors are 
modeled as crayons, and groups of crayons are stored in crayonboxes. 
 
The Custom Crayons command opens the Custom Crayons Editor.  The operation of this editor 
is described in detail by clicking here. 
 
This command is identical to the Custom Crayons button on the Edit Toolbar and the Custom 
Crayons button in the Photo Edit Tools. 
 
 

Cross Stitch Symbols 
 
pbnArtist allows you to manage the symbols that are assigned to stitches in cross stitch 
patterns. 
 
The Cross Stitch Symbols command opens the Cross Stitch Symbols Collection.  The operation 
of this editor is described in detail by clicking here. 
 
This command is identical to the Cross Stitch Symbols button on the Edit Toolbar and the 
Symbols button in the Step 3 -- Cross Stitch tab in the Quickstart Panel. 
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Paint Brush 
 
The Paint Brush command allows you to paint a solid color onto your photograph, by stroking 
over the region you wish to color.  The brush's color, size, and feather option can be set in the 
Photo Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Paint Brush button on the Edit Toolbar and the Paint Brush 
button in the Photo Edit Tools. 
 

Paint Bucket 
 
The Paint Bucket command allows you to fill a rectangular region of your photograph with a 
solid color, by selecting and adjusting the region and then clicking the mouse within the 
selection area to finalize the operation.  The bucket's color and feather option can be set in the 
Photo Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Paint Bucket button on the Edit Toolbar and the Paint Bucket 
button in the Photo Edit Tools. 
 

Soften Brush 
 
The Soften Brush command allows you to soften the focus in a portion of your photograph, by 
stroking over the region you wish to soften.  This can help remove detail from parts of your 
drawing that have too many lines.  The amount of softening can be set in the Photo Edit Tools, 
where you will also find more information about this tool's operation. 
 
This command is identical to the Soften Brush button on the Edit Toolbar and the Soften Brush 
button in the Photo Edit Tools. 
 

Soften Bucket 
 
The Soften Bucket command allows you to soften the focus in a rectangular region of your 
photograph, by selecting and adjusting the region and then clicking the mouse within the 
selection area to finalize the operation.  This can help remove detail from parts of your drawing 
that have too many lines.  The amount of softening can be set in the Photo Edit Tools, where 
you will also find more information about this tool's operation. 
 
This command is identical to the Soften Bucket button on the Edit Toolbar and the Soften 
Bucket button in the Photo Edit Tools. 
 

Enhance Brush 
 
The Enhance Brush command allows enhance the brightness, contrast or saturation in a region 
of your photograph, by stroking over the region you wish to enhance.  This can help increase 
the detail in important areas of your drawing.  The brightness, contrast and saturation amounts 
can be set in the Photo Edit Tools, where you will also find more information about this tool's 
operation. 
 
This command is identical to the Enhance Brush button on the Edit Toolbar and the Enhance 
Brush button in the Photo Edit Tools. 



pbnArtist User’s Manual 
 

  
Page 99 

 
  

Enhance Bucket 
 
The Enhance Bucket command allows you to enhance the brightness, contrast or saturation of 
a region of your photograph, by selecting and adjusting the region and then clicking the mouse 
within the selection area to finalize the operation.  This can help increase the detail in important 
areas of your drawing.  The brightness, contrast and saturation amounts can be set in the Photo 
Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Enhance Bucket button on the Edit Toolbar and the Enhance 
Bucket button in the Photo Edit Tools. 
 
 

Patch and Pixel Sampler 
 
This command actives the Patch and Pixel Sampler, which displays numerical values of the 
colors within the sampled pixels, and the crayon assigned to the selected region.  Click here for 
a detailed description of this tool's operation.  
 
This command is identical to the Patch and Pixel Sampler button on the Edit Toolbar. 
 
 

Sketchline Pencil 
 
The Sketchline Pencil command allows you to draw a line onto the paint-by-number drawing.  
Click here for a detailed description of its operation. 
 
This command is identical to the Sketchline Pencil button on the Edit Toolbar. 
 
 

Sketchline Eraser 
 
The Sketchline Eraser command allows you to erase sketchlines from your paint-by-number 
drawing.  Click here for a detailed description of its operation. 
 
This command is identical to the Sketchline Eraser button on the Edit Toolbar. 
 
 

Patch Crayon Changer 
 
This button actives the Patch Crayon Changer, which allows you to change the crayons 
assigned to individual patches in your drawing, and to individual stitches in a cross stitch 
pattern.  Click here for a detailed description of this tool's operation.  
 
This button is identical to the Patch Crayon Changer button on the edit toolbar. 
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Photo Tool Settings 
 
This command opens the Photo Edit Tools window, which allows you to adjust the settings for 
the photo editing tools. 
 
This command is identical to the Brush and Bucket Settings command in the Edit Toolbar and 
the Edit Photo button in Step 1 of the Quickstart Panel. 
 
 

Drawing Tool Settings 
 
This command opens the Drawing Edit Tools window, which allows you to adjust the settings for 
the drawing editing tools. 
 
This command is identical to the Eraser Settings command in the Edit Toolbar and the Edit 
Drawing button in Step 3 of the Quickstart Panel. 
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View Menu 

 

 
 
These are the commands that are available in the View Menu. 
 
 

Zoom 
 
The Zoom command sets the size of the picture displayed in the project workspace.  You may 
select from any of several fixed sizes, or you may select the Fit option, which fits the picture to 
the size of the workspace. 
 
This command is identical to the Zoom drop-down list on the Standard Toolbar. 
 
 

Toolbars 
 
The Toolbars command enables or disables viewing of the Quickstart Panel, the Standard 
Toolbar and the Edit Toolbar. 
 
 

Drawing, Cross Stitch, Photo 
 
The three check items labeled Drawing,  Cross Stitch, and Photo are used to select the view 
displayed in step 3.  Below each of these is a menu item labeled options, which lets you select 
the options for each view. 
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Help menu 

 

 
 
These are the commands that are available in the Help Menu. 
 
 

Contents 
 
The Contents command opens the user manual (this document) with its table of contents 
displayed. 
 
This command is identical to the Help button on the Standard Toolbar. 
 
 

Search 
 
The Search command opens the user manual (this document) with its search window displayed. 
 
 

Index 
 
The Index command opens the user manual (this document) with its index displayed. 
 

Show Popups 
 
When you allow the cursor to hover over a button, a popup will appear giving you a brief 
description of the item. 
 
The Show Popups command enables or disables viewing of these popups. 
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Show Tip Of The Day 
 
The Show Tip Of The Day command allows you to view the current tip-of-the-day, as well as to 
scroll forward or backward through all of the available suggestions. 
 
 

Program Activation 
 
The Program Activation command displays a window that gives information about the program's 
activation license, and allows you to activate the program if you have not already done so. 
 
 

Check For Updates 
 
The Check For Updates command accesses the internet to determine if a newer version of 
Paint-By-Number Artist is available.  If a newer version is available, a window will open that 
gives you the option to download it. 
 
After downloading the new version, you should exit out of Paint-By-Number Artist and then 
install the new version by double-clicking the file that you just downloaded. 
 
 

About pbnArtist 
 
The pbnArtist command displays a window that gives information about this program. 
 
  



pbnArtist User’s Manual 
 

  
Page 104 

 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This page has been intentionally left blank. 
 

 
 
 
 
 
 
 
 
 
 
 
 
  



pbnArtist User’s Manual 
 

  
Page 105 

 
  

 

 

Quickstart Panel 
 

Summary 

 
The Quickstart Panel contains only the commands you need to create a paint-by-number 
drawing from a photograph.  It provides a simple, three-step approach. 
 
The panel is divided into three tabbed sections, labeled Step 1, Step 2 and Step 3.  You can 
jump to the desired step by clicking the tab at the top of the panel. 
 
 

Enabling the Quickstart Panel 
 
The Quickstart Panel can be shown or hidden using the Toolbars command in the View Menu, 
or by clicking the Toggle Quickstart Panel button on the Standard Toolbar. 
 
 

  Resize 
 
The Quickstart Panel can be resized.  To resize it, move the cursor to the right side of the 
panel.  When the cursor changes to the image above, click and drag it to the desired size. 
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Step 1 

 

 
 
 
In Step 1, you open a digital photograph file and select the settings you will use to create a 
paint-by-number drawing. 
 
Step 1 has a basic mode and an advanced mode.  Its commands are described here. 
 
 

Photograph Type Selection Slider 
 
Use the adjustment slider to select the type of photograph.  There are five possible selections, 
based primarily on the image's focus, ranging from sharpest (Sharp Graphics) to softest (Hazy 
Photo). 
 
Use Sharp Graphics for images that were drawn with a graphics program.  Use the other 
settings for photographs, depending on the sharpness or clarity of the photograph. 
 
In most cases, you should use the second choice from the left, labeled Sharp Photo.  After you 
have processed the photograph, you may wish to return to this step to experiment with the other 
choices. 
 
This adjustment is identical to the options available under Process Settings --> Photograph 
Type in the Edit Menu. 
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New Button 
 
The New button creates a new project and allows you to open an image file to place into this 
project. 
 
The command opens a window that lets you navigate to and select an image file.  The directory 
will initially be the same directory you have previously used for opening or saving graphics 
images.  The file type is set to All Image Files but you can also specify individual graphics 
formats. 
 
This command is identical to the New Project From Photograph command in the File Menu, and 
the Create New Project button on the Standard Toolbar. 
 
 

Open Button 
 
The Open Project button opens an existing project file. 
 
The command opens a window that lets you navigate to and select a project file.  The directory 
will initially be the same as the directory you have previously used for opening or saving project 
files.  The file type is set to PbnArtist project files, which have the extension .pbn added to their 
file name. 
 
This command is identical to the Open Project command in the File Menu, and the Open 
Existing Project button on the Standard Toolbar. 
 
 

Close Button 
 
The Close button closes the current project file.  You will be given the option to save it if it has 
changed since the last time you saved it. 
 
 

Advanced Tabs 
 
The advanced tabs are described in the following pages. 
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Crayons Tab  

 

 
 
pbnArtist provides several groups of colors that you may include in your drawing.  These colors 
are grouped into Crayonboxes.  Click the dropdown arrow to view the list of crayonboxes and to 
choose the collection you would like to use. 
 
The dropdown box shows crayonboxes that are included with the program (system 
crayonboxes) and any custom crayonboxes that you have added or created.  Click here to learn 
how to create custom crayons.  Click here to learn how to import custom crayonboxes from an 
external file. 
 
The list below the crayonbox shows the crayons within the crayonbox.  The program 
automatically analyzes the colors in your photograph and then sorts the crayonbox, so that 
crayons at the top of the list represent the colors most frequently used in your photo. 
 
A number next to each crayon shows the percentage of the photograph that uses that color. 
 
A checkbox next to each crayon allows you to specify whether a crayon should be used or not.  
The program will assign the checked crayons to the colors in your photograph.  At each pixel in 
the photo, the program will select the closest crayon from the crayons you have checked, 
attempting to find the best crayon to match the color in that pixel. 
 
You must have at least one crayons checked before proceeding to step 2. 
 
The Number of Crayons numerical entry box below the list of crayons allows you to specify how 
many crayons should be included in your drawing.  Simply enter the number you desire, or use 
the up/down arrows to increase or decrease the number. 
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Color Matching Tab 
 

 
 
pbnArtist allows you to adjust the color-matching that is used to select crayons for your 
drawing.  You adjust the brightness, contrast, saturation and tint in the crayons that are selected 
and assigned to your drawing. 
 
When you change a color matching value, you are telling the program to select crayons based 
on the change you have made.  So for example, if you increase the brightness slider, you are 
telling the program to try to find crayons that are brighter than the actual pixel colors. 
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Tools Tab 
 

 
 
You can edit the original photo by clicking the Editing Tools  button.  This provides you with 
tools that can crop the photo, paint colors onto the photo, soften the focus in parts of the photo, 
or enhance the brightness, contrast and saturation of parts of the photo.  Editing the photograph 
is explained in detail here. 
 
The Image Size button allows you to resample the photograph (changing its resolution) and to 
specify the size (in inches or centimeters) of your drawing.  The image size window is described 
in detail here. 
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Step 2 
 
 

 
 
In Step 2 you will process the photograph, converting it into a paint-by-number drawing.  There 
is only one command in this step. 
 
 

Run Button 
 
The Run button activates the process, converting your photograph into a paint-by-number 
drawing. 
 
When you press this button, its text will change to Cancel as shown here, and the process will 
begin. 
 
This command is identical to the Process Photograph command in the Edit Menu, and the 
Process Photo button on the Edit Toolbar. 
 
 

 
 

Cancel Button 
 
While the process is running, if you decide you would like to stop the process, you may do so by 
pressing the Cancel button. 
 
This button is identical to the Cancel Process command in the Edit Menu, and the Cancel button 
on the Edit Toolbar. 
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Step 3 

 

 
 
In Step 3, you will decide how you would like to view your pbnArtist project.  You can view your 
project as a drawing (paint-by-number or coloring picture) or as a cross stitch (or needlepoint) 
pattern. 
 
To select the project type, click either the Drawing tab or the Cross Stitch tab.  The options 
provided under these tabs are described in the next pages. 
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Drawing Tab 

 
Use the drawing tab to view your project as a paint-by-number or a coloring picture.  You can 
set the complexity as well as determine how to display numbers and lines within the picture.  
What follows is a brief description of how these options work.  You can find more details by 
clicking here. 
 

Select the Drawing View. 
 
Use the radio buttons to select the view being displayed.  You may select from the following 
views: 

 Numbers: 
This view shows your paint-by-number picture, including numbers indicating the colors to 
be used. 
 

 No Numbers: 
This view shows your paint-by-number drawing without including the color numbers.  
This is useful for a coloring picture. 

 

 Colored: 
This view shows your drawing with the colors filled-in. 
 

 Key: 
This view shows the list of crayons to use to color your drawing. 
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Adjust the Drawing Complexity. 
 
Use the sliders to adjust the difficulty level of your drawing. 
 
The drawing includes two types of lines: sketch lines and patch lines.  Sketch lines are used to 
add a more lifelike appearance to your picture.  Patch lines are used to show exactly where the 
colors may be filled in. 
 
Both sketchlines and patchlines can be adjusted using the adjustment sliders.  Moving the 
sliders to the left will reduce the amount of detail shown in your picture.  Moving them to the 
right will increase the amount of detail. 
 
 

Additional Settings in the Drawing Tab 
 
The next set of checkboxes allow you to select how numbers are displayed for very small 
patches of color in your picture.  You may elect to have the number offset from a patch with an 
arror pointing into the center of the patch, or you may elect to not display numbers for these 
small patches. 
 
Below these checkboxes is a set of radio buttons that allow you to select the type of drawing 
being displayed.  You may select sketch mode or patch mode, or a combination of both.  Sketch 
mode draws lines that give a more lifelike view of your picture, as shown below.  Patch mode 
draws lines exactly where the colors change, giving a view that will show the actual colors more 
accurately after the picture has been painted or colored. 
 

 
 

Number Spacing 
 
The Number Spacing numerical entry box lets you adjust the maximum distance between the 
numbers that indicate crayon colors on you picture.  This value may be specified in inches or 
centimeters by checking the appropriate radio button. 
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Font Button 
 
The Font button allows you to specify the font used for color numbers in your paint-by-number 
view. 
 
 

Tools Button 
 
The Tools button provides tools that can draw or erase lines on your drawing, and that can 
change the crayons that are used for portions of your drawing. 
 
Editing the drawing using these tools is explained in detail here. 
 
 

Size Button 
 
The size button allows you to specify the size of your drawing (in inches or centimeters) when it 
is printed.  You also have the option to print the drawing on a single page of paper or across 
multiple pages. 
 
 

Icon Button 
 
The Icon button changes the icon that is used in the color key.  The color key provides a list of 
the colors used in your picture.  Each color is shown using an icon.  The available icons are 
crayon, pencil, pen, chalk, marker, paint brush, spool of thread, ball of yarn, button, or text only. 
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Cross Stitch Tab 

 

 
 
Use the cross stitch tab to view your project as a cross stitch or needlepoint pattern.  You can 
set the size and stitch count as well as determine how to display floss symbols and/or colors 
within the pattern.  What follows is a brief description of how these options work. 
 

Select the Cross Stitch View. 
 
Use the radio buttons to select the view being displayed.  You may select from the following 
views: 

 Pattern: 
This view shows your cross stitch or needlepoint pattern, including symbols indicating 
the flosses to be used. 
 

 Key: 
This view shows the list of flosses to use in your cross stitch or needlepoint project.  This 
key is slightly different from the key given in the drawing tab.  The flosses are identified 
by a symbol rather than a number. 



pbnArtist User’s Manual 
 

  
Page 117 

 
  

Stitch Count and Size 
 
The set of numeric boxes near the top of this window allow you to set the stitch count (number 
of stitches per inch or per centimeter) to agree with the fabric you are using for your cross stitch 
project, and the total size of your project, counted in stitches.  The program automatically 
displays this size converted to either inches or centimeters, so as you change the number of 
stitches you can see the equivalent size. 
 

Title and Header 
 
This checkbox causes patterns to be displayed with a title and additional information at the top 
of the page.  If the pattern is large enough to cover multiple pages, the header also includes a 
map of the pages which shows where each page fits into the overall pattern. 
 
If you want your pattern to fit on one page, you will probably need to have this option turned off. 
 

Grid Numbers 
 
Your project have numbers along the sides of the pattern, making it easier to count stitches, or 
you can leave these out. 
 

Stitch Symbols 
 
Your pattern can display symbols for each floss being uses, or you can turn this option off and 
show the floss color instead.  When using symbols, the program selects from the character fonts 
available on your computer. 
 

Stitch Colors 
 
Select this option to display the floss color for every stitch shown in your pattern. 
 

Backstitches 
 
The sketch mode lines, described for the drawing tab, can be overlaid on top of your cross stitch 
pattern.  These can be shown as individual stitches (single strands that extend horizontally, 
vertically, or diagonally across individual intersections in the weave) or as a line drawing (similar 
to the sketch line mode in the drawing tab).  You can change the color, thickness, and 
complexity level of these backstitches by clicking the Settings: button. 
 

Highlight 
 
This function allow you to print a highlighted version of the cross stitch pattern, that is, a pattern 
in which all stitches from an individual thread are highlighted.  The options button lets you 
specify the color to be used for the highlight, and it lets you select the thread or threads to be 
highlighted.  Note that one copy of the pattern will be produced for each thread you select, so 
this may result in very many pages being printed. 
 
The highlighted plan that you select will appear in the main window, and will print when you 
select the print function. 
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Portrait or Landscape 
 
Your cross stitch pattern can be printed from any computer picture.  This option selects whether 
the pattern will be printed vertically (portrait) or horizontally (landscape) on the page.  If the 
pattern is too large to fit on a single sheet of paper, it will automatically be spread across 
multiple pages.  (You can return it to a single page by reducing the size of the project or by 
selecting smaller font sizes). 
 
 

Number Stitches From 
 
This option is used along with the Show Grid Numbers option.  You can elect to have the stitch 
numbering start from any corner or from the center of the pattern. 
 
 

Font Button 
 
You can use the font button to specify the font used for the title and labels shown on your cross 
stitch pattern. 
 
 

Tools Button 
 
You can used the tools button to activate editing tools to make changes to your pattern.  You 
can change the colors that are used for individual stitches or for groups of stitches.  Editing a 
cross stitch pattern is similar to editing a coloring or paint-by-num picture, and is described in 
more detail here. 
 
 

Symbols Button 
 
Cross stitch patterns show the floss used for each stitch by showing a symbol that is unique for 
each stitch.  pbnArtist uses the character fonts that are available on your computer, primarily 
using dingbat font types if they are available on your computer.  You can change the collection 
of symbols by clicking the symbols button. 
 
For more fun with your cross stitch patterns, you might enjoy adding additional symbol fonts.  
There are a wide variety of symbol fonts available on the internet, and many of these fonts are 
available for free.  To find these, search the internet using the search term "dingbat fonts." 
 
After you have found and installed new symbol fonts onto your computer, use the symbols 
button to select and add each symbol to your collection. 
 
 

Icon Button 
 
The Key view shows each floss used in your pattern, drawing each floss as a colored icon.  
Normally, it uses the default icon that is defined for each crayonBox, but you can use the icon 
button to select a different icon.  
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Photo Tab 
 

 
 
Use the photo tab to view your original photograph. 
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Toolbars 

 
 

 

Standard Toolbar 

 
 

 
 
The Standard Toolbar provides buttons that access the most commonly used standard 
commands. 
 
 

Enabling The Toolbar 
 
The Standard Toolbar can be shown or hidden using the Toolbars command in the View Menu. 
 
 
 

  Docking Handle 
 
This toolbar is dockable, which means it can be moved around in the workspace.  It can be 
docked to any one of the four sides of the workspace. 
 
To move the toolbar, select the docking handle and drag it to the desired side of the workspace. 
 
 

  Create New Project From Photograph 
 
The Create New Project From Photograph button creates a new project and allows you to open 
an image file to place into this project. 
 
The command opens a window that lets you navigate to and select an image file.  The directory 
will initially be the same directory you have previously used for opening or saving graphics 
images.  The file type is set to All Image Files but you can also specify individual graphics 
formats. 
 
This command is identical to the New Project From Photograph command in the File Menu, and 
the New button in Step 1 of the Quickstart Panel. 
 

 



pbnArtist User’s Manual 
 

  
Page 122 

 
  

 
 

  Open Existing Project 
 
The Open Existing Project command opens an existing project file. 
 
The command opens a window that lets you navigate to and select a project file.  The directory 
will initially be the same as the directory you have previously used for opening or saving project 
files.  The file type is set to PbnArtist project files, which have the extension .pbn added to their 
file name. 
 
This command is identical to the Open Project command in the File Menu , and the Open button 
in Step 1 of the Quickstart Panel. 
 
 

  Save Project 
 
This command saves your project file.  If this is the first time you have saved the project, then 
the command automatically runs the Save Project As ... command in the File Menu, which asks 
you to provide a file name and location before saving the file. 
 
This command is identical to the Save Project command in the File Menu. 
 
 

  Print Current View 
 
Sends the current view to the printer. 
 
This command is identical to the Print command in the File Menu. 
 

  Cut 
 
The Cut button removes a rectangular portion of your image and replaces it with a white 
rectangle.  The cut portion is available for a later Paste operation.  The Cut button may be used 
on either the Photograph or the Drawing views. 
 
To use this button, click the button and then drag the cursor across the rectangular region that 
you wish to cut.  A selection rectangle will be drawn that indicates the region to be cut. 
 
The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
 
You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
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You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the cutting tool without using it, click the Cut button a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Cut 
button.  When used this way, the cut operation will happen immediately. 
 
This button is identical to the Cut command in the Edit Menu and the Cut button in the Photo 
Edit Tools.  When the tool is active, a box will surround its button on the Standard Toolbar, and 
a check will appear next to the command on the Edit Menu. 
 

  Copy 
 
The Copy button copies a rectangular portion of your image and replaces it with a white 
rectangle.  The copied portion is available for a later Paste operation, and may also be used to 
copy the current view into another computer program.  The Copy button may be used on either 
of the Photograph, Drawing, or Color Key views. 
 
To use this button, click the button and then drag the cursor across the rectangular region that 
you wish to copy.  A selection rectangle will be drawn that indicates the region to be copied. 
 
The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
 
You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
 
You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the copy tool without using it, click the Copy button a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Copy 
button.  When used this way, the copy operation will happen immediately. 
 
This button is identical to the Copy command in the Edit Menu and the Copy button in the Photo 
Edit Tools.  When the tool is active, a box will surround its button on the Standard Toolbar, and 
a check will appear next to the command on the Edit Menu. 
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  Paste 
 
The Paste button pastes an image that you have previously cut or copied, onto your 
photograph.  The Paste button may only be used on the Photograph view.  Pasting is not 
available for any of the Drawing views. 
 
To use this button, begin by using either the Cut command or the Copy command, or you may 
also use the equivalent of these commands in another computer program.  Click the Paste 
button, and a preview of your cut or copied image will appear over a rectangular portion of your 
photograph, with a selection rectangle drawn around it. 
 
You may adjust the size of the image by dragging any of its sides or corners to a desired 
location, or you may move the entire image by dragging its upper-left corner.  Hold down the 
Shift key while you are adjusting the image's size to maintain its original aspect ratio. 
 
When you are satisfied with the image's size and location, move the cursor to the interior of the 
selection rectangle and click the mouse. 
 
If you would like to cancel the operation, move the cursor outside of the rectangle and click the 
mouse.  You can also cancel the operation by clicking the Paste button a second time.  The 
preview of the copied image will disappear. 
 
This button is identical to the Paste command in the Edit Menu and the Paste button in the 
Photo Edit Tools.  When the tool is active, a box will surround its button on the Standard 
Toolbar, and a check will appear next to the command on the Edit Menu. 
 
 

  Select All 
 
This button is useful when used with the Cut command or the Copy command.  To select the 
entire image, click the Select All button.  To cancel the selection, click the button a second time. 
 
This button is identical to the Select All command in the Edit Menu. 
 
 

 

  Crop 
 
The Crop button resizes your image and removes anything that is outside of the rectangular 
selection region.  The Crop button may only be used on the Photograph view.  Cropping is not 
available for any of the Drawing views. 
 
To use this button, click the button and then drag the cursor across the rectangular region that 
you wish to cropped.  A selection rectangle will be drawn that indicates the region to be 
cropped. 
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The shape of the selection rectangle is controlled by the Photo Tool Settings.  You may specify 
a fixed aspect ratio (ratio between height and width), or you may specify a variable (free-format) 
aspect ratio.  In free-format mode, you may also force the rectangle to be square by holding 
down the Shift key as you drag the cursor across the selection. 
 
You can access these settings by running the Photo Tool Settings command in the Tools Menu, 
by clicking the Edit Photo button in Step 1 of the Quickstart Panel, or by clicking the Brush and 
Bucket Settings button on the Edit Toolbar. 
 
You may adjust the size of the selection rectangle by dragging any of its sides or corners to a 
desired location, or you may move the entire rectangle by dragging its upper-left corner. 
 
When you are satisfied with the selection, move the cursor to the interior of the selection 
rectangle and click the mouse.  If you would like to cancel the operation, move the cursor 
outside of the rectangle and click the mouse. 
 
To deselect the cropping tool without using it, click the Crop button a second time. 
 
You may also use this tool by selecting your selection rectangle first, and then clicking the Crop 
button.  When used this way, the crop operation will happen immediately. 
 
This button is identical to the Crop command in the Edit Menu and the Crop button in the Photo 
Edit Tools.  When the tool is active, a box will surround its button on the Standard Toolbar, and 
a check will appear next to the command on the Edit Menu. 
 
 

  Zoom 
 
The Zoom button sets the size of the picture displayed in the project workspace.  You may 
select from any of several fixed sizes, or you may select the Fit option, which fits the picture to 
the size of the workspace. 
 
This button is identical to the Zoom command in the View Menu. 
 
 

  Toggle Quickstart Panel 
 
The Toggle Quickstart Panel button enables or disables viewing of the Quickstart Panel. 
 
 

  Help 
 
The Help button opens the user manual (this document) with its table of contents displayed. 
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Edit Toolbar 

 

 
 
The Edit Toolbar provides buttons that access the most commonly used commands for 
processing or modifying your photograph or drawing. 
 
 

Enabling The Toolbar 
 
The Edit Toolbar can be shown or hidden using the Toolbars command in the View Menu. 
 
 

  Docking Handle 
 
This toolbar is dockable, which means it can be moved around in the workspace.  It can be 
docked to any one of the four sides of the workspace. 
 
To move the toolbar, select the docking handle and drag it to the desired side of the workspace. 
 
 

  Undo 
 
Many of Paint-By-Number Artist's commands can be undone.  For example, if you are using the 
Paintbrush to paint a color onto your photograph, and you change your mind, you can remove 
individual brush stroke's by running this command. 
 
This button will indicate if it is available or not, by whether its color is blue (available) or gray 
(unavailable). 
 
This command is identical to the Undo command in the Edit Menu. 
 
 

  Redo 
 
If you have used to the Undo command to undo an operation, you can re-apply the operation by 
using the Redo command. 
 
This button will indicate if it is available or not, by whether its color is blue (available) or gray 
(unavailable). 
 
This command is identical to the Redo command in the Edit Menu. 
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  Process Photograph 
 
This button processes your photograph into a paint-by-number drawing.  Click it when you are 
satisfied with your photograph or any changes you have made to the photograph or any of the 
settings. 
 
This button is identical to the Run button in Step 2 of the Quickstart Panel, and the Process 
Photograph command in the Edit Menu. 
 
 

  Cancel 
 
This button cancels the Process Photograph command while it is running, in case you have a 
reason to cancel the process.  Click it once while the process is running, and wait for the 
process to stop. 
 
This button is identical to the Cancel button in Step 2 of the Quickstart Panel, and the Cancel 
Process command in the Edit Menu. 
 
 

  Custom Crayons 
 
pbnArtist allows you to manage the colors that are included in your drawings.  Colors are 
modeled as crayons, and groups of crayons are stored in crayonboxes. 
 
The Custom Crayons command opens the Custom Crayons Editor.  The operation of this editor 
is described in detail by clicking here. 
 
This command is identical to the Custom Crayons command in the Tools Menu and the Custom 
Crayons button in the Photo Edit Tools. 
 
 

  Cross Stitch Symbol Collection 
 
pbnArtist allows you to manage the symbols that are assigned to stitches in cross stitch 
patterns. 
 
The Cross Stitch Symbols command opens the Cross Stitch Symbols Collection.  The operation 
of this editor is described in detail by clicking here. 
 
This command is identical to the Cross Stitch Symbols command in the Tools Menu and the 
Symbols button in the Step 3 -- Cross Stitch tab in the Quickstart Panel. 
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  Paint Brush 
 
The Paint Brush command allows you to paint a solid color onto your photograph, by stroking 
over the region you wish to color.  The brush's color, size, and feather option can be set in the 
Photo Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Paint Brush command in the Tools Menu and the Paint Brush 
button in the Photo Edit Tools. 
 
 

  Soften Brush 
 
The Soften Brush command allows you to soften the focus in a portion of your photograph, by 
stroking over the region you wish to soften.  This can help remove detail from parts of your 
drawing that have too many lines.  The amount of softening can be set in the Photo Edit Tools, 
where you will also find more information about this tool's operation. 
 
This command is identical to the Soften Brush command in the Tools Menu and the Soften 
Brush button in the Photo Edit Tools. 
 
 

  Enhance Brush 
 
The Enhance Brush command allows enhance the brightness, contrast or saturation in a region 
of your photograph, by stroking over the region you wish to enhance.  This can help increase 
the detail in important areas of your drawing.  The brightness, contrast and saturation amounts 
can be set in the Photo Edit Tools, where you will also find more information about this tool's 
operation. 
 
This command is identical to the Enhance Brush command in the Tools Menu and the Enhance 
Brush button in the Photo Edit Tools. 
 
 

  Paint Bucket 
 
The Paint Bucket command allows you to fill a rectangular region of your photograph with a 
solid color, by selecting and adjusting the region and then clicking the mouse within the 
selection area to finalize the operation.  The bucket's color and feather option can be set in the 
Photo Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Paint Bucket command in the Tools Menu and the Paint 
Bucket button in the Photo Edit Tools. 
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  Soften Bucket 
 
The Soften Bucket command allows you to soften the focus in a rectangular region of your 
photograph, by selecting and adjusting the region and then clicking the mouse within the 
selection area to finalize the operation.  This can help remove detail from parts of your drawing 
that have too many lines.  The amount of softening can be set in the Photo Edit Tools, where 
you will also find more information about this tool's operation. 
 
This command is identical to the Soften Bucket command in the Edit Tools Menu and the Soften 
Bucket button in the Photo Edit Tools. 
 
 

  Enhance Bucket 
 
The Enhance Bucket command allows you to enhance the brightness, contrast or saturation of 
a region of your photograph, by selecting and adjusting the region and then clicking the mouse 
within the selection area to finalize the operation.  This can help increase the detail in important 
areas of your drawing.  The brightness, contrast and saturation amounts can be set in the Photo 
Edit Tools, where you will also find more information about this tool's operation. 
 
This command is identical to the Enhance Bucket command in the Tools Menu and the 
Enhance Bucket button in the Photo Edit Tools. 
 
 

  Brush and Bucket Settings 
 
This button opens the Photo Edit Tools window, which allows you to adjust the settings for the 
photo editing tools. 
 
This button is identical to the Photo Tool Settings command in the Tools Menu and the Edit 
Photo button in Step 1 of the Quickstart Panel. 
 
 

  Patch and Pixel Sampler 
 
This button actives the Patch and Pixel Sampler, which displays numerical values of the colors 
within the sampled pixels, and the crayon assigned to the selected region.  Click here for a 
detailed description of this tool's operation.  
 
This button is identical to the Patch and Pixel Sampler command in the Tools Menu. 
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  Sketchline Pencil 
 
The Sketchline Pencil button allows you to draw a line onto the paint-by-number drawing.  Click 
here for a detailed description of its operation. 
 
This command is identical to the Sketchline Pencil command in the Tools Menu. 
 
 

  Sketchline Eraser 
 
The Sketchline Eraser button allows you to erase sketchlines from your paint-by-number 
drawing.  Click here for a detailed description of its operation. 
 
This command is identical to the Sketchline Eraser command in the Tools Menu. 
 
 

  Patch Crayon Changer 
 
This button actives the Patch Crayon Changer, which allows you to change the crayons 
assigned to individual patches in your drawing, and to individual stitches in a cross stitch 
pattern.  Click here for a detailed description of this tool's operation.  
 
This button is identical to the Patch Crayon Changer command in the Tools Menu. 
 
 

  Eraser Settings 
 
This button opens the Drawing Edit Tools window, which allows you to adjust the settings for the 
drawing editing tools. 
 
This button is identical to the Drawing Tool Settings command in the Tools Menu and the Edit 
Drawing button in Step 3 of the Quickstart Panel. 
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Editing Tools 

 
 
 

Image Size Window 

 

 
 
The photograph can be resampled, which means its resolution can be changed, using the 
Image Size command in the File Menu.  You can change this value by adjusting either the width 
or height of the picture in pixels, or by entering a total number of megapixels.  (When you enter 
a total amount, it may be necessary for the program to adjust the number slightly so that the 
ratio of width to height doesn't change). 
 
This window can also be used to specify the size of drawing views, in inches or centimeters.  
You may select a size that is larger than a single sheet of paper.  When you do this, drawings 
will automatically be printed across multiple sheets of paper. 
 
Sometimes it is desirable to save a drawing view as a graphics file but to have it split across 
multiple files, so that the saved files will be identical to large views that were printed across 
several pages.  Clicking the Split Saved Graphics ... checkbox will automatically save views into 
multiple graphics files. 
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Photo Edit Tools 

 
 

 
 
The Photo Edit Tools dialog contains tools that let you modify your original photograph.  The 
sections of the dialog and the tools provided are described here. 
 
 

Activating The Tool 
 
The Photo Edit Tools dialog can be activated from Step 1 of the Quickstart Panel, from the 
Brush and Bucket Settings button on the Edit Toolbar, and from the Photo Tool Settings 
command in the Tools Menu. 
 
 

Custom Crayons 
 
Although not technically a photo edit tool, this dialog also provides you with a means to access 
the Custom Crayons Editor. 
 
 

Operation of the cut, copy, paste and crop tools 
 
The cut, copy and crop tools are described below.  These tools allow you to select a rectangular 
region of the photograph, and then remove or copy it. 
 
Normally, tools of this type allow users to select a region that has any size.  However, for 
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photography and art, it is sometimes beneficial to select a size that has a specific aspect ratio 
(ratio between height and width), because aspect ratio can have a strong impact on a picture's 
composition.  The Aspect ratio section of the dialog lets you select whether the selected area is 
free-form (variable aspect ratio) or has a fixed aspect ratio.  It also lets you select either a 
vertically oriented (Portrait) or a horizontally oriented (Landscape) region. 
 
The cut, copy and crop tools all work as follows.  To select a region, drag the mouse across the 
region.  A rectangle will appear that indicates the region that was selected. 
 
To adjust the size of the region, move the cursor to a side or corner point on the rectangle and 
drag that point to its desired new location.  (The cursor will change to indicate that clicking and 
dragging will move that point to a new location). 
 
To move the entire rectangle to a new region, move the cursor to the upper-left corner and drag 
it to the desired location.  (The cursor will change to indicate that clicking and dragging it will 
move the entire rectangle to a new location). 
 
To cancel the selection, move the cursor outside of the selected region and click.  (The cursor 
will change to indicate that clicking will cancel the selection). 
 
To finalize the selection, move the cursor inside the selected region and click.  (The cursor will 
change to indicate that clicking will finalize the selection). 
 
 

  Cut tool 
 
The cut tool deletes the selected portion of the photograph, replacing it with a white rectangle, 
and copying the selected portion into the Windows clipboard.  Once cut, this region may be 
pasted onto another portion of the photograph, or into another software program. 
 
When the cut tool is selected, the cursor will change to the above symbol.  Operation is as 
described above. 
 
 

  Copy tool 
 
The copy tool copies a rectangular portion of the photograph into the Windows clipboard.  Once 
copied, this region may be pasted onto another portion of the photograph, or into another 
software program. 
 
When the copy tool is selected, the cursor will change to the above symbol.  Operation is as 
described above. 
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  Paste tool 
 
After the cut or copy tools have been used, the paste tool may be used to insert the cut or 
copied portion onto another part of the photograph.  Click the mouse to insert a preview the 
copied portion onto the photograph.  A rectangle will be placed around the new portion, 
indicating that it can be moved or resized before finalizing (or canceling) the operation. 
 
When the paste tool is selected, the cursor will change to the above symbol.  Moving the cursor 
to different parts of the preview will cause it to change, indicating the action that will happen if 
you click the mouse. 
 
 

  Crop tool 
 
The crop tool resizes the photograph, eliminating any parts of the photo that are outside of the 
selected rectangle. 
 
When the crop tool is selected, the cursor will change to the above symbol.  Operation is as 
described above. 
 
 

  Operation of the Brush and Bucket Tools 
 
Brush and bucket tools are provided to make other modifications to your photograph. 
 
When using a brush, the operation will only apply to a region that you stroke, similar to using an 
actual paint brush. 
 
All brushes have a size that you can change using the Brush Size adjustment slider.  Each 
brush cursor includes a circle that indicates the size of the brush and the region that will be 
affected by the brush. 
 
Brushes also have a Feather mode, that softens the effect near the edge of the brush. 
 
When using a bucket, you will have the opportunity to select a rectangular region of the 
photograph, and then apply the operation to that region.  The operation is similar to spilling a 
bucket into an entire region. 
 
 

Paint Brush and Bucket 
 
The paint tool applies a solid color to part of the photograph.  You can select the color by 
pressing the Color button.  You can specify a color or select from one of the current crayons.   
 
If you have selected the Use Color Wheel option, pressing the Color button will activate the 
Color Editor tool, which allows you to specify a color directly, or select a color by clicking a 
region of the photograph using the Pixel Sampler. 
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If you have selected the Use Crayon Colors, pressing the Color button will activate the Crayon 
Chooser, from which you can select the crayon color you wish to use. 
 
 

Soften Brush and Bucket 
 
The soften tool allows you to soften the focus, or even blur, part of the photograph.  You can 
select the amount of softening by setting the Softness adjustment slider. 
 
When creating a paint-by-number drawing, you can use the soften tool to remove detail from a 
portion of the photograph.  You will usually find that the end result is very sensitive to this 
adjustment, so it is best to start with small amounts of softness and experiment with increasing 
values. 
 
 

Enhance Brush and Bucket 
 
The enhance tool allows you to enhance part of the photograph, by adjusting its brightness, 
contrast and saturation.  These values can be changed by setting the Brightness, Contrast and 
Saturation adjustment sliders, or by inserting numerical values in the number boxes above 
these sliders. 
 
When creating a paint-by-number drawing, you can use the enhance tool to add detail to a 
portion of the photograph.  You will find that, although this tool may exaggerate the appearance 
of the original photograph, it can add desirable detail to the final drawing. 
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Drawing Edit Tools 

 

 
 
The Drawing Edit Tools dialog contains tools that let you modify your paint-by-number drawing.  
The sections of the dialog and the tools provided are described here. 
 
 
 

Activating The Tool 
 
The Drawing Edit Tools dialog can be activated from Step 3 of the Quickstart Panel, from the 
Eraser Settings button on the Edit Toolbar, and from the Drawing Tool Settings command in the 
Tools Menu. 
 
 
 

  Patch and Pixel Sampler 
 
The patch and pixel sampler lets you select individual pixels in either your original photograph or 
your final drawing.  It displays the color of the original pixel and the crayon selected to represent 
that pixel.  The pixel color is the average of all of the pixels within the circle indicated on this 
cursor.  If you have not yet generated a paint-by-number picture, then the crayon is actually a 
prediction of the crayon that will probably be used for this pixel. 
 
This tool allows you to change the crayon selected for a region of the final drawing.  It also 
allows you to copy a pixel's color into the Color Editor tool.  It's operation is described in full 
here. 
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  Sketchline Pencil 
 
The sketchline pencil allows you to draw a line onto the paint-by-number drawing.  This tool is 
only available after you have generated a paint-by-number drawing from your original 
photograph. 
 
This tool will draw a line when you click the mouse and drag it.  Before clicking the mouse, the 
cursor will show a "+" that indicates the exact location where the line will be drawn. 
 
The line drawn will be identical to other sketchlines.  The color and thickness of these lines can 
be adjusted using the View --> Drawing Options command in the View Menu or the Line Style 
button adjacent to the Sketch Mode radio button in Step 3 of the Quickstart Panel. 
 
 

  Sketchline Eraser 
 
The sketchline eraser allows you to erase lines from your paint-by-number drawing.  This tool is 
only available if you have generated a paint-by-number drawing from your original photograph. 
 
This tool will erase any sketch line that falls within the region indicated by the circle in the 
cursor.  The size of this region may be changed by setting the Eraser Size adjustment slider. 
 
Note that the lines being erased are sketch lines, which means they are the lines that appear 
when the drawing is viewed in Sketch Mode.  Patch lines will not be erased.  To erase patch 
lines, use the Drawing Complexity slider for Color Patches in Step 3 of the Quickstart Panel. 
 
 

  Patch Crayon Changer 
 
The patch crayon changer lets you select individual patches in a drawing view and assign 
different crayons to them.  Its operation is described in full here. 
 
 
 
 
 
 
 
 
 
 
 
 
  



pbnArtist User’s Manual 
 

  
Page 138 

 
  

 

Patch and Pixel Sampler 

 

 
 
The patch and pixel sampler lets you sample pixels in your photograph and patches of crayon 
colors in your paint-by-number drawing.  It is useful for analyzing the colors in your drawing, for 
changing the crayon used in a part of the drawing, and for creating new crayons from a scanned 
color sample. 
 
The tool displays the color value of the pixels being sampled and the crayon selected for that 
region of the photograph.  If you have not yet processed your photograph into a paint-by-
number drawing, then the tool forecasts the crayon that will be selected based on the current 
settings. 
 
 

Activating The Tool 
 
The Patch and Pixel Sampler can be activated from the Tools Menu, from the Edit Toolbar, from 
the Color Editor, and from the Drawing Edit Tools dialog. 
 
 

  The Cursor 
 
When the patch and pixel sampler tool is selected, the cursor will change to the above image 
when it is over your picture.  This image will appear whenever the cursor is over the photograph 
or drawing. 
 
The circle on this image indicates the region of pixels that will be sampled.  When you click the 
mouse, the sampler will report the average color of all of the pixels that are within the sampling 
region.  The size of this region can be changed using the Sample Size adjustment described 
below. 
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Cursor Location 
 
This value indicates the location of the pixels you have selected.  The location is given as a pair 
of {x, y} coordinates, counting the number of pixels horizontally from the left side of the 
photograph, and downward from the top of the photograph.  The upper-left corner has location 
{0, 0}.  The point reported is the center of the circular region you have selected. 
 
 

Actual Color 
 
This value indicates the numerical color value of the pixels you have selected, using the 
average of all pixels in the selected region.  The value is given in LAB coordinates. 
 
 
 

Selected Crayon / Nearest Crayon 
 
This picture shows the crayon selected to represent the region of pixels you have selected. 
 
If you are viewing the paint-by-number drawing (using either the Color-By-Numbers, Line 
Drawing, or Color Drawing view), this picture shows the actual crayon (Selected Crayon) that 
was selected. 
 
If you are viewing the original photograph (using the Photograph view), this picture shows the 
crayon that is nearest to the color of the selected pixels, which might be different from the actual 
crayon used in your drawing.  You can experiment by changing the crayonbox, colorspace, or 
selected crayons to see which crayon would have been selected for this part of your picture. 
 
If you are viewing the color key (using the Color Key view), the sampler will sample the color 
key icons and show the colors and nearest crayons of the pixels in these icons. 
 
The label above the picture gives the numerical value of the color used for this crayon, reported 
in LAB coordinates. 
 
 

Distance 
 
This value reports the distance from the pixels' color to the crayon's color.  This distance is the 
value the program uses to select the nearest crayon. 
 
 
 

Sampler Size 
 
This adjustment slider allows you to change the size of the region of pixels that will be selected 
by the patch and pixel sampler.  The size of this region is indicated by the circle on the cursor. 
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Change Crayon 
 
Activates the Patch Crayon Changer tool, which allows you to change the crayon used for the 
selected region of pixels.  This button is only available after you have generated a paint-by-
number drawing from your original photograph. 
 
 

Using the Sampler with the Color Editor 
 
The patch and pixel sampler can also be used to sample colors into the color editor.  When the 
color editor is active, moving the cursor into the work area (on the program's main window) 
automatically changes it to the eyedropper cursor.  Sampling a color in the work area will 
automatically transfer that color into the color editor, and select its location in the displayed color 
space. 
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Patch Crayon Changer 

 

 
 
The Patch Crayon Changer tool lets you change the crayon assigned to a region (patch) in your 
paint-by-number picture.  The patch that will be affected must be selected using the Patch and 
Pixel sampler.  The tool allows you to replace a single color patch, or replace all patches that 
have the same original crayon assigned to them. 
 
 

Activating The Tool 
 
The Crayon Chooser can be activated from the edit toolbar or the tools menu.  Once activated, 
any changes made will be applied to the colored region of the drawing (patch) that was selected 
by the Patch and Pixel Sampler. 
 
The Crayon Changer tool is only available after you have processed your photograph into a 
paint-by-number drawing or a cross stitch pattern. 
 
 

  The Cursor 
 
When the patch crayon changer tool is selected, the cursor will change to the above image 
when it is over your picture.  This image will appear whenever the cursor is over the photograph 
or drawing. 
 
The cross on this image indicates the location that will be changed. 
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Using the tool 
 
When the tool is active, you move the cursor over the drawing, to the patch or color that you 
would like to change.  When you click on that point, the crayon will change to the one you have 
selected (below).  If you have set the tool to change multiple patches, all patches that have the 
same crayon will change to the new crayon. 
 
 

Quick Sample (Shift Click) 
 
When the tool is active, you can shift click (hold the keyboard's SHIFT key while clicking) on a 
point on the drawing to quickly set that crayon as the selected crayon in the tool. 
 
 

Apply Choice To 
 
You can change the crayon for all patches that use the same crayon as the selected patch, a 
single selected patch, or a single selected stitch (in cross stitch view). 
 
 

Reset All Crayons 
 
You can quickly undo all changes you have made by clicking the Reset All Crayons button. 
 
 

Crayon List 
 
This list displays the crayons that may be assigned to the patch.  The list only displays crayons 
that are in the crayonbox selected for this project, which is set in Step 1 of the Quickstart Panel.  
The name of the selected crayonbox is shown above the list. 
 
To change a patch, select the desired crayon from this list, and then move the cursor to the 
patch you want to change and click on it.  You will see the change immediately in Drawing mode 
if the current view is either Numbers or Colored, or in Cross Stitch mode if the view is Pattern 
and either Show Stitch Symbols or Show Stitch Colors is selected. 
 
 

Using The "Reset:" Crayon 
 
Selecting Reset: in the crayon list will cause selected patches or stitches to be returned to their 
original crayon. 
 
 

Using The "<Blank>" Crayon 
 
Selecting <Blank> in the crayon list will cause the selected patches or stitches to be set so that 
they have no crayon assigned to them.  This can be useful on cross stitch patterns if you wish to 
use the fabric as the background color. 
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Crayon Symbols 
 
The list of crayons will show colors using the default icon for the current crayonBox.  Each 
crayon will show its number within the collection.  If the current view is a cross-stitch pattern, 
then crayons that are currently in use on the pattern will also show the cross stitch symbol 
assigned to them (as on the Green crayon in the above picture).  When you add new crayons to 
a cross stitch pattern, they will automatically have symbols assigned to them as well. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



pbnArtist User’s Manual 
 

  
Page 144 

 
  

 

Custom Crayons Editor 

 

 
 
The Custom Crayons Editor allows you to create new crayonboxes that can be used in your 
pictures.  Crayons can be created by editing colors directly, by copying crayons from other 
crayonboxes, or by selecting colors on an existing photograph. 
 
The term crayon is used somewhat generically.  Crayons can also represent pencils, paints, 
markers, chalk and other artistic media.  Crayons are grouped together into crayonboxes, 
making it possible to specify an individual group of crayons when you are creating a paint-by-
number drawing. 
 
The commands in the Custom Crayons Editor are divided into four sections, labeled Select 
Crayon Box, Select Crayon(s), Edit Crayon Box, and Edit Crayon.  The four sections are 
explained below. 
 
 

Activating The Tool 
 
The Custom Crayons Editor can be activated from the Photo Edit Tools dialog, from the Custom 
Crayons button on the Edit Toolbar, and from the Custom Crayons command in the Tools 
Menu. 
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Select Crayon Box Section 
 
Use the commands in the Select Crayon Box section to create and modify crayonboxes.  
Crayonboxes are used to keep crayons together in groups, so that a specific group of crayons 
can be specified when you are creating a paint-by-number drawing. 
 
Select the crayonbox that you wish to modify from the list.  Only custom crayonboxes are 
displayed.  System crayonboxes that are built-in to Paint-By-Number Artist are not displayed 
because these can not be modified. 
 
You can modify this list, using the buttons immediately below the list. 
 
The New Crayon Box button creates a new unnamed crayon box.  You will have to assign a 
name and icon for this box using the commands in the Edit Crayon Box section. 
 
The Remove Box deletes a crayonbox from the list.  Be careful when using this command.  It 
removes an entire crayonbox from the program, and this can not be undone. 
 
The Import From File button opens a file dialog that allows you to select a file containing other 
crayonboxes.  Crayonbox files have names that end in the .pbx extension.  This command is 
identical to the Import Custom Crayons command in the File Menu. 
 
The Export To File button opens a dialog that allows you to save crayonboxes into an external 
file.  You may select any number of your custom crayonboxes to include in this file.  Crayonbox 
files have names that end in the .pbx extension.  This command is identical to the Export 
Custom Crayons command in the File Menu. 
 
You can move boxes up and down within the list, using the arrow buttons at the right side of the 
list. 
 
 

Select Crayon(s) Section 
 
Use the commands in the Select Crayon(s) section to select individual crayons to be modified.  
Once selected, crayons can be modified using the commands in the Edit Crayon section. 
 
It is possible to select multiple crayons at the same time.  Use the shift key or the ctrl key when 
clicking a crayon in order to add it to the selection. 
 
Commands that are within this section can be applied to a group of crayons.  However, the 
commands that are in the Edit Crayon section will only be applied to the top crayon in a selected 
group. 
 
You can modify the list of crayons, using the buttons in this section. 
 
The New Crayon button adds a new crayon to the list, immediately below the selected crayon or 
group of crayons.  The new crayon will be unnamed and have a gray color.  You will need to 
assign a key, name and color using the commands in the Edit Crayon section. 
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The Remove Crayon will remove the selected crayon or the selected group of crayons from the 
list.  Be careful when using this command -- it can not be undone. 
 
The Copy From ... button opens a new dialog box that allows you to select crayons from other 
crayonboxes.  This dialog allows you to select from custom crayonboxes as well as the built-in 
system crayonboxes.  Crayons that are copied from other crayonboxes will have their names, 
key numbers, and colors copied into the new crayonbox, but they will be drawn with the icon 
assigned to this crayonbox. 
 
The Renumber All button replaces the crayon keys with numbers, beginning with 1 and 
continuing to the end of the list. 
 
The arrow buttons on the right side of the list enable you to move a crayon or group of crayons 
up or down within the list. 
 
 

Edit Crayon Box Section 
 
Use the commands in the Edit Crayon Box section to rename a crayonbox and to assign an icon 
to this crayonbox.  There are several icons available, including crayon, pencil, pen, marker, 
narrow paint brush, wide paint brush, and more. 
 
Use the Reset button if you change your mind and want to cancel changes made. 
 
Use the Save Changes button to make your changes permanent and to apply them to the 
selected crayonbox. 
 
 

Edit Crayon Section 
 
Use the commands in the Edit Crayon section to modify the crayon that is selected in the Select 
Crayon(s) section.  If multiple crayons are selected, the commands in this section will be applied 
only to the top crayon in the selection. 
 
You may change the color of a crayon using the Edit Color button.  This button activates the 
Color Editor, which allows you to specify colors by selecting predefined colors or from a color 
wheel, by entering numeric values for a color, or by sampling a portion of your photograph. 
 
Enter a name for this crayon into the box entitled Long Name.  This name will appear in the 
color key created for each paint-by-number drawing. 
 
Enter a key for this crayon into the box entitle Key (number or short name).  This key may be a 
number or an abbreviation using either numbers or text.  The key will appear in your paint-by-
number picture to identify the crayon to use for each color patch. 
 
You can automatically assign a number to the key by pressing the Use Next Number button.  
You can also assign keys to all of the crayons automatically by pressing the Renumber All 
button in the Select Crayon(s) section. 
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Use the Reset button to undo any changes you have made in this section. 
 
When you are satisfied with the changes you have made to the selected crayon, press the Save 
Changes button in this section. 
 
 

Finishing and Closing the Custom Crayons Editor 
 
When you are satisfied with all of the changes you have made to your crayonboxes, press the 
Close button.  This will insert all of the custom crayonboxes into the list shown in Step 1 of the 
Quickstart Panel.  This will also run a process which analyzes and profiles all of your crayons.  It 
may take a minute or so for the profiling process to complete. 
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Color Editor:  Basic View 

 

 
 
 
The Color Editor can be used to select or create colors that can be used to create new crayons 
and to set line and font colors on your paint-by-number drawing.  Colors can be selected from 
all colors available to your computer, which usually amount to millions of possibilities. 
 
The Basic View of this tool allows you to select colors from a predefined set of colors, from a 
Color Wheel type of display, or from a photograph using the Pixel Sampler. 
 
 

Activating The Tool 
 
The Color Editor can be activated from the Custom Crayons Editor, from the Line Style settings 
in Step 3 of the Quickstart Panel, and from the Font Style settings in Step 3 of the Quickstart 
Panel. 
 
 

Preset Colors 
 
Click any one of the colored boxes in this section to select that color.  Allowing the cursor to 
hover over a box will display the name of that color, if you have enabled the Show Popups 
option in the Help Menu. 
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The boxes are arranged with commonly-used colors at the top, and grayscale colors at the 
bottom.  The three rows of grayscale colors include so-called warm grays, neutral grays, and 
cool grays. 
 
 

Color Selector 
 
In basic view, the Color Selector displays a color wheel and a vertical brightness bar.   
 
Move the slider adjacent to the brightness bar up or down to adjust the brightness of the colors 
available in the color wheel. 
 
Select a color within the wheel by moving the cursor to that position and clicking the mouse 
button. 
 
 

  Patch and Pixel Sampler 
 
You may also select a color by sampling a portion of your photograph, using the Patch and Pixel 
Sampler. 
 
Move the cursor into the program's main window.  When it is over the photograph, the cursor 
will change to the image shown above. 
 
Click the mouse button to sample the pixels that are within the circle on the cursor.  The 
indicator in the Color Selector will immediately move to the color which is the average of the 
pixels within this circle. 
 
You can change the size of the circular sampling region by moving the Sampler adjustment 
slider near the bottom of the Color Editor. 
 
 

Advanced Button 
 
Clicking the Advanced button displays and enables the additional commands that are available 
in the Color Editor's Advanced mode. 
 
 

Finishing and Closing the Color Editor 
 
When you are satisfied with the color you have selected, click the Save button.  Or if you have 
changed your mind and do not wish to use the color you have selected, click either the Cancel 
button or the Reset button. 
 
Closing the Color Editor will cause the color you have selected to be applied to the tool that was 
used to activate the color editor. 
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Color Editor:  Advanced View 

 

 
 
 
The Color Editor also has an advanced view.  This mode of operation allows you to work with all 
of the colorspaces used by Paint-By-Number Artist, and it allows you to enter numeric values for 
colors in addition to the other selection methods. 
 
 

Activating The Tool 
 
The Color Editor advanced view can be activated by clicking the Advanced button in the Color 
Editor basic view. 
 
 

Mode 
 
Selecting one of these mode causes the Color Selector to display colors using the colorspace 
you have selected.  You may select colors using the RGB, HLS, or LAB colorspaces.  Click here 
to read more about the colorspaces used in Paint-By-Number Artist. 
 
In RGB mode, the Color Selector will display a square representing the red and green values.  
Red is measured from left-to-right, and Green is measured vertically within this square.  The 
vertical bar will represent the blue value.  
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In HLS mode, the Color Selector will display a circle representing the Hue and Saturation 
values.  Hue is measured in degrees as the angular position around the circle (counter-
clockwise), and Saturation is measured as the distance from the center of the circle.  The 
vertical bar will represent the Luminosity value. 
 
In LAB mode, the Color Selector will display a complex shape representing the A and B values.  
A is measured from left-to-right, and B is measured from bottom-to-top within this shape.  The 
vertical bar will represent the L value. 
 
 

Selector Scale 
 
The shape of the HLS and LAB colorspaces causes them to become narrower when the vertical 
bar is at its high or low ends.  You can see this affect by selecting the True Size option, or you 
can compensate for this affect by selecting the Fill Window option. 
 
When the Color Editor is in Basic mode, the color wheel being displayed is actually using the 
HLS colorspace mode with the selector scale set to Fill Window. 
 
 

Numerical Entry Boxes 
 
Advanced mode also allows you to enter numerical values directly for the color you are 
selecting.  You can enter or view any of the L, A, B values for the LAB colorspace, the H, L, S 
values for the HLS colorspace, or the R, G, B values for the RGB colorspace. 
 
 

Basic Button 
 
The Basic button returns the Color Editor to its Basic mode. 
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Cross Stitch Symbol Collection 

 

 
 
Accessing the cross stitch symbol collection will open the window shown above.  In this window 
you can select the actual symbols that will be assigned to the stitches in your project.  These 
symbols come from the character fonts that are available in your computer. 
 
 

Activating the editor 
 
The Cross Stitch Symbol Collection Editor can be activated from the the Cross Stitch Symbol 
Collection button on the Edit Toolbar, from the Cross Stitch Symbols command in the Tools 
Menu, and by clicking the Symbols button in the Step 3 -- Cross Stitch tab in the Quickstart 
panel. 
 
 

Using the editor 
 
Symbols will be assigned to colors in the order they are listed in this collection.  The symbol at 
the top of the list will be assigned to the most frequently used color, or floss, in your project. 
 
The left side of this window allows you to examine each font type that is available in your 
computer.  Some font types are divided into multiple groups.  If that is the case for the font you 
are examining, the number of groups available will be displayed along with the currently 
selected group number. 
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The right side of this window shows the symbols that you have included in your font collection. 
 
To add a symbol to your collection, select the desired symbol on the left side of this window, 
and click the right arrow (-->) in the middle of the window. 
 
Each symbol will be added at the currently selected location.  If you would like to move a symbol 
up or down within your collection, select the symbol and click either the up arrow or the down 
arrow. 
 
If you would like to remove a symbol from your collection, select the symbol (in the right side of 
this window) and click the left arrow (<--). 
 
You can also set the size of all of the symbols in the collection.  The symbol size will affect how 
large your cross stitch pattern is when printed on paper.  For very large projects, you may wish 
to use a smaller font size so that the pattern can be printed on a single page.  In other cases, 
you might wish to use a larger font size to make the pattern more readable, and to make it 
easier for a person to count stitches. 
 
You can also select whether the symbols should be printed using regular, bold, or italic type.  
(Bold and italic options are not available for all font types, so these settings might not be applied 
to your entire collection). 
 
To have some fun, insert additional character fonts onto your computer and add them to your 
symbol collection.  There are hundreds of symbol fonts available on the internet, and many of 
them are available for free.  To find new fonts, search the internet using the search term 
"dingbat fonts".  Follow the provider's directions to insert new fonts onto your computer, and 
then use this tool to add them to your cross stitch symbol collection. 
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Colorspaces 

 
 

How pbnArtist uses Colorspaces 

 
pbnArtist uses a computer algorithm to match crayons to the colors in your photograph.  The 
goal is that the program should always select the same crayon that a human would select when 
matching these colors.  This task is straightforward for humans, but it is more complicated for 
computers because computers don't perceive colors the way humans do. 
 
In order to choose the crayons to match the colors in your photograph, Paint-By-Number Artist 
must examine each pixel in the photograph and choose the crayon that is closest to the color in 
that pixel.  But the concept of closeness is not defined for colors.  So the program must first 
assign a position to each color, and then use this position to find the crayon that is closest to 
each color in your photograph. 
 
pbnArtist uses the LAB Colorspace to arrange colors in three-dimensional space in order to 
select the crayons that match each pixel. 
 
The Color Editor allows you to display colors using the LAB colorspace, and also allows you to 
display colors using the RGB and HLS colorspaces.  
 
These three colorspaces are described in the following sections, in order from the simplest to 
the most complex colorspace. 
 
The RGB Colorspace 
 
The HLS Colorspace 
 
The LAB Colorspace 
 
Other Colorspaces 
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The RGB Colorspace 

 

 
 
The RGB (Red, Green, Blue) colorspace arranges colors in a three-dimensional cube.  Each 
direction in this cube relates to one of the three colors that computer monitors and digital 
photographs use to construct colors.  If you start in the black corner, proceeding in any one of 
these three directions shows the effect of adding more and more of that particular color. 
 
If on the other hand, you start at the white corner, proceeding in any one of these three 
directions shows the effect of removing that color from white light.  This is the same as adding 
the complementary colors of red, green and blue, which are cyan, magenta and yellow.  This 
second group of colors are the three colors that are combined in computer printers to construct 
colors. 
 
The RGB colorspace is available in the Color Editor tool, when it is used in its advanced mode.  
The cross-sections below show how the RGB colorspace appears when it is used in the color 
editor tool. 
 
 

RGB Cross Sections (Top View): 
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The HLS Colorspace 

 
 
The HLS (Hue, Luminosity, Saturation) colorspace arranges colors in a three-dimensional 
double cone.  You can think of this shape as a three-dimensional version of the color wheels 
that are used in some art classes.  The colors are arranged around this double cone, 
progressing in a circle around the vertical axis. 
 
Hue, which we typically think of as a color's name, is found by measuring the position, or angle , 
found if you follow this circle counter-clockwise around the vertical axis.  Hue is measured in 
degrees (°), with values from 0° to 360°.  Some commonly recognized colors around this axis 
are red (0° or 360°), orange (30°), yellow (60°), green (120°), cyan (180°), blue (240°), violet 
(270°) and magenta (300°). 
 
Luminosity is a color's brightness.  It has values that range from 0 to 100.  Black has a value of 
0, white has a value of 100, and the other colors have luminosity values between 0 and 100.  In 
the HLS colorspace, luminosity is indicated by a color's vertical height in the double-cone 
structure. 
 
Saturation is a color's richness.  Colors with large values of saturation are what we typically 
think of as colors, while colors that have small saturation values are what we typically think of as 
grays.  In the HLS colorspace, saturation is determined by finding a color's distance from the 
vertical axis.  In other words, saturation is the distance from the center of the circle.  It has 
values that range from 0 to 50.  All of the fully-saturated colors are positioned at the far reaches 
of the double-cone, while white, black, and the grays lie on the central axis of the double-cone 
structure. 
 
The HLS colorspace is available in the Color Editor tool, in both basic mode and advanced 
mode.  The cross-sections below show how this colorspace looks in the color editor tool. 
 
Notice that the cross-sections get narrower for colors that are near the top or bottom of the 
luminosity scale.  This is because of the colorspace's double-cone structure.  This narrowing 
effect can be compensated by using the color editor's Fill Window option. 
 

HLS Cross Sections (Top View): 
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The LAB Colorspace 

 
 
The LAB (pronounced "Ell-Aye-Bee") colorspace arranges colors in a complicated three-
dimensional shape.  This colorspace was developed to represent the way humans perceive 
colors.  Its intention is that the distance between any two colors should be the same as the 
difference that humans perceive between them.  Paint-By-Number Artist uses this characteristic 
to find the crayon that is closest to each pixel in a photograph. 
 
The letters in LAB's name don't mean anything -- they are just three random letters used to label 
the three axes in the shape.  The "L" direction (vertical) represents the brightness or darkness of 
a color.  The horizontal directions represent a color's warmth, with the "A" direction displaying 
warmth and coolness in terms of red and magenta versus cyan and green, and the "B" direction 
displaying warmth and coolness in terms of yellow versus blue. 
 
The LAB colorspace was developed in the 1920's and 1930's, primarily by the Commission 
Internationale de l'Eclairage (International Commission on Illumination) in France, based on 
experiments on how humans perceive colors.  It is commonly used in other software programs 
to color-correct digital photographs.  If you would like to learn more about using the LAB 
colorspace for this purpose, you may be interested in the book Photoshop LAB Color:  The 
Canyon Conundrum and Other Adventures in the Most Powerful Colorspace, by Dan Margulis. 
 
pbnArtist uses the LAB colorspace to match crayons to the colors in a photograph.  A benefit of 
the LAB colorspace (over the HSL and RGB colorspaces) is that it is specifically designed to 
mimic the way humans think about colors, therefore it will usually select the same crayon a 
human would select. 
 
The LAB colorspace is also available in the Color Editor tool, when it is used in its advanced 
mode.  The cross-sections below show how this colorspace looks in the color editor. 
 
Notice that the cross-sections get narrower for colors that are near the top or bottom of the L 
axis.  This is because the colorspace also gets narrower in these regions, as can be seen in the 
3-dimensional picture above.  This narrowing effect can be compensated by using the color 
editor's Fill Window option. 
 

LAB Cross Sections (Top View): 
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Other Colorspaces 

 
There are dozens of other colorspaces that can be used to arrange colors in three-dimensions.  Although 
they are not used in pbnArtist, a few of them are described here. 
 
The HSB Colorspace 
 

 
 
The HSB colorspace (Hue, Saturation, Brightness) arranges colors in a three-dimensional cylinder.  It is 
similar to the HLS colorspace, which arranges colors in a three-dimensional double-cone. 
 
The CMY(K) Colorspace 
 

 
 
If you are familiar with inks used by your computer printer, then you are probably aware that your printer 
uses the CMY colorspace (sometimes called CMYK).  The letters in this name stand for the colors of the 
inks being used, which are Cyan, Magenta, Yellow, and sometimes blacK. 
 
The CMY colors are complements to red, green and blue, which are used in the RGB colorspace.  The 
picture above shows that the CMY colorspace can be represented by the same cube that represents the 
RGB colorspace, and simply orienting it from the its white corner. 
 
The RYB Colorspace 
 

 
 
The RYB (Red, Yellow, Blue) colorspace is used by painters and other artists to represent three colors 
that can be combined to construct other colors. 
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